[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Linux-cluster] CS4 U2 / problem to configure a 3 nodes cluster



Alain Moulle wrote:
> Hi
> 
> I'm trying to configure a simple 3 nodes cluster
> with simple tests scripts.
> But I can't start cman, it remains stalled with
> this message in syslog :
> Apr 10 11:37:44 s_sys yack21 ccsd: startup succeeded
> Apr 10 11:38:00 s_kernel yack21 kernel: CMAN 2.6.9-39.5 (built Sep 20 2005
> 16:04:34) installed
> Apr 10 11:38:00 s_kernel yack21 kernel: NET: Registered protocol family 30
> Apr 10 11:38:00 s_sys yack21 ccsd[25004]: cluster.conf (cluster name =
> HA_METADATA_3N, version = 8) found.
> Apr 10 11:38:00 s_kernel yack21 kernel: CMAN: Waiting to join or form a
> Linux-cluster
> Apr 10 11:38:01 s_sys yack21 ccsd[25004]: Connected to cluster infrastruture
> via: CMAN/SM Plugin v1.1.2
> Apr 10 11:38:01 s_sys yack21 ccsd[25004]: Initial status:: Inquorate
> Apr 10 11:38:32 s_kernel yack21 kernel: CMAN: forming a new cluster
> 
> and nothing more.
> 
> The graphic tool dos not detect any error in configuration; I 've
> attached my cluster.conf for the three nodes, knowing that
> I wanted two nodes (yack10 and yack21) running theirs applications
> and the 3rd one (yack23) as a backup for yack10 and/or yack21,
> but I don't want any failover between yack10 and yack21.
> 
> PS : I 've verified all ssh connections between the 3 nodes, and
> all the fence paths as described in the cluster.conf.
> Thanks again for your help.

Check that the cluster ports are not blocked by any firewalling. You'll
need 6809/udp & 21064/tcp opened.
-- 

patrick


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]