[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Linux-cluster] cluster suite and webfarm + GFS ???



sure here is my latest cluster.conf.
Note that on this one the is no gfs service. I trying to fixe my httpd
prob (httpd up on all nodes) before adding gfs in the game :-)
thanks !

<?xml version="1.0"?>
<cluster config_version="39" name="webfarm">
        <fence_daemon post_fail_delay="0" post_join_delay="3"/>
        <clusternodes>
                <clusternode name="lecce" votes="1">
                        <fence>
                                <method name="1">
                                        <device name="manual_fencing"
nodename="lecce"/>
                                </method>
                        </fence>
                </clusternode>
                <clusternode name="cagliari" votes="1">
                        <fence>
                                <method name="1">
                                        <device name="manual_fencing"
nodename="cagliari"/>
                                </method>
                        </fence>
                </clusternode>
        </clusternodes>
        <cman expected_votes="1" two_node="1"/>
        <fencedevices>
                <fencedevice agent="fence_manual" name="manual_fencing"/>
        </fencedevices>
        <rm>
                <failoverdomains>
                        <failoverdomain name="lecce-gfs" ordered="0"
restricted="1">
                                <failoverdomainnode name="lecce"
priority="1"/>
                        </failoverdomain>
                        <failoverdomain name="cagliari-gfs" ordered="0"
restricted="1">
                                <failoverdomainnode name="cagliari"
priority="1"/>
                        </failoverdomain>
                </failoverdomains>
                <resources>
                        <script file="/etc/init.d/httpd"
name="httpd-lecce"/>
                        <script file="/etc/init.d/httpd"
name="httpd-cagliari"/>
                </resources>
                <service autostart="1" domain="lecce-gfs" name="web-lecce">
                        <script ref="httpd-lecce"/>
                </service>
                <service autostart="1" domain="cagliari-gfs"
name="web-cagliari">
                        <script ref="httpd-cagliari"/>
                </service>
        </rm>
</cluster>






------------------------------------
Frédéric Médery
Administrateur Système /
System Administrator
LexUM, Université de Montréal
email : mederyf lexum umontreal ca
tel.  : (514) 343-6111  p. 1-3288
fax. : (514) 343-7359
------------------------------------



Lon Hohberger wrote:
> On Mon, 2006-08-14 at 13:28 -0400, FM wrote:
>   
>> Hello,
>> After 1 week of trial and error, and a lot of reading, I still cannot
>> figure out how-to configure :
>> 3 webservers (behind director servers using piranha_gui) connected to a
>> GFS file system (on a LUN).
>>
>> What I am trying to achieve :
>> 3 servers connected to a GFS file system. the web root is on the GFS
>> file system. HTTPD up on all servers for failover/load balancing (httpd
>> is monitored by the director servers).
>> The prob is the link httpd/gfs. if I loose the GFS link, httpd will
>> still response to the director, but the information will be missing.
>> That's where, I suppose, cluster suite takes place. But I am unable to
>> have httpd+gfs activated on each node at the same time !
>>
>> I tried :
>> 1 failover domain per node + 1service per failover domain + 1 resource
>> 1 failover domain per node + 1service per failover domain + 1 resource
>> per service
>>
>> All failed to achieve my goal  !
>>
>> Can someone have a clue ? I suppose I'm not the first to try this.
>>     
>
> Could you post one of your configurations?
>
> -- Lon
>
>
> --
> Linux-cluster mailing list
> Linux-cluster redhat com
> https://www.redhat.com/mailman/listinfo/linux-cluster
>   


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]