[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Linux-cluster] GFS for Linux kernel 2.6.16 and Xen 3.0.2_2



Hi,

On Friday 18 August 2006 18:20, Robert Hatch wrote:
> Hi, I am running the current testing version of Debian and I have been
> trying to compile the cluster source into my custom kernel.  I have
> successfully built and booted from a 2.6.16.27 kernel with latest Xen
> 3.0.2-2 stable support but I have failed to successfully compile the cluster
> suite.  I have been using ./configure --kernel_src=/PATH and then make
> install as advised but the build process always fails and I have tried this
> using both the current stable CVS and 1.02.00 tarball (which progresses
> further).  I have read that others have had very similar problems
> http://lists.xensource.com/archives/html/xen-users/2006-07/msg00620.html but
> later report they solve the problems by installing certain packages
> http://lists.xensource.com/archives/html/xen-users/2006-07/msg00730.html.
> This has not worked for me although the errors they report are identical. I
> was wondering if anyone knew a solution to this problem or possibly a list
> of dependent packages and versions that are required to compile Redhat
> cluster suite.  The only thing I can currently think of is that my
> ncurses5-dev package is somehow incompatible with the build.

I also had the problem with the same configuration (Linux kernel 2.6.16,
Xen 3.0.2-2, cluster-1.02.00 tarball). Here is how I solved it:

1) Install the required packages.

2) Apply the patch that is listed at
   http://www.redhat.com/archives/cluster-devel/2006-June/msg00162.html.
   This will solve the problem 'error: dereferencing pointer to
   incomplete type' (as stated in
   http://lists.xensource.com/archives/html/xen-users/2006-07/msg00730.html).

3) Some further error occured, stating that some header files could not
   be found. You can fix it on your own when you just change the
   '#include' statement (I cannot tell you exactly now where to fix it,
   because I cannot access that computer, see the error message from the
   compiler). I remember that a 'magma.h' and another file were included in
   the wrong way (the given path was wrong). After I changed the '#include'
   statement in the source it compiled fine.

As far as I remember that was all what was needed to let me compile the
cluster-1.02.00.

Hope this helps,
Thomas


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]