[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Linux-cluster] Cluster fail over fails when umounting fs



On Fri, Aug 18, 2006 at 01:46:10PM -0400, Lon Hohberger wrote:
Can you post your service blob from cluster.conf?

<?xml version="1.0"?>
<cluster config_version="17" name="dcdb">
  <fence_daemon post_fail_delay="0" post_join_delay="3"/>
  <clusternodes>
     <clusternode name="hadrian" votes="1">
        <fence>
           <method name="1">
              <device name="hadrian-ilo"/>
           </method>
        </fence>
     </clusternode>
     <clusternode name="caesar" votes="1">
        <fence>
           <method name="1">
              <device name="caesar-ilo"/>
           </method>
        </fence>
     </clusternode>
  </clusternodes>
  <cman expected_votes="1" two_node="1"/>
  <fencedevices>
     <fencedevice agent="fence_ilo" hostname="172.16.112.30" login="Administrator" name="hadrian-ilo" passwd="****"/>
     <fencedevice agent="fence_ilo" hostname="172.16.112.31" login="Administrator" name="caesar-ilo" passwd="****"/>
  </fencedevices>
  <rm>
     <failoverdomains/>
     <resources>
        <fs device="/dev/sda1" force_fsck="0" force_unmount="1" fsid="57931" fstype="ext3" mountpoint="/db2" name="db2" options="" self_fence="1"/>
        <ip address="172.16.1.205" monitor_link="1"/>
        <script file="/etc/rc.d/init.d/db2" name="db-init"/>
     </resources>
     <service autostart="1" name="db2" recovery="restart">
        <fs ref="db2"/>
        <ip ref="172.16.1.205"/>
        <script ref="db-init"/>
     </service>
  </rm>
</cluster>


--
Neil Watson             | Gentoo Linux
System Administrator    | Uptime 25 days
http://watson-wilson.ca | 2.6.16.19 AMD Athlon(tm) MP 2000+ x 2


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]