[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

RE: [Linux-cluster] cman can not start



Dear Robert

The firewall is disabled on the server.
What should I check?

BR;
Fadia
-----Original Message-----
From: linux-cluster-bounces redhat com
[mailto:linux-cluster-bounces redhat com] On Behalf Of Robert Peterson
Sent: Monday, August 28, 2006 11:23 PM
To: linux clustering
Subject: Re: [Linux-cluster] cman can not start

Fadia Al-Marei wrote:
>
> Dear All
>
> I have two redhat Enterprise Linux 4 AS servers with shared storage , 
> I try to cluster them , I download the cluster suite packages on the 
> two servers and it ok, when I start to add nodes on the cluster the 
> problems start , in the first server I add the two nodes start the 
> ccsd service and the cman service and every thing is ok, when I ftp 
> the file to the second server and try to start the ccsd and the cman 
> services I face the problems and the log file show the errors.
>
>  
>
> Aug 28 10:28:02 CluServ2 cman: startup succeeded
> Aug 28 10:28:07 CluServ2 kernel: CMAN: sendmsg failed: -13
> Aug 28 10:28:12 CluServ2 kernel: CMAN: sendmsg failed: -13
> Aug 28 10:28:12 CluServ2 kernel: CMAN: No functional network 
> interfaces, leaving cluster
> Aug 28 10:28:12 CluServ2 kernel: CMAN: sendmsg failed: -13
> Aug 28 10:28:12 CluServ2 kernel: CMAN: we are leaving the cluster.
> Aug 28 10:28:12 CluServ2 kernel: WARNING: dlm_emergency_shutdown
> Aug 28 10:28:12 CluServ2 kernel: WARNING: dlm_emergency_shutdown
> Aug 28 10:28:12 CluServ2 ccsd[31038]: Cluster manager shutdown. 
> Attemping to reconnect...
> Aug 28 10:28:33 CluServ2 ccsd[31038]: Unable to connect to cluster 
> infrastructure after 30 seconds.
>
>  
>
> What is the problem and how can I solve it.
>

Hi Fadia,

Sounds like the cluster manager can't communicate between the nodes.
Check to make sure the iptables firewall isn't filtering out messages 
between
the nodes, (i.e. temporarily turn it off and try again).  If it is 
iptable interfering,
you may need to enable some ports in iptables.  See 
http://sources.redhat.com/cluster/faq.html#iptables

Also, check to make sure that broadcast messages work properly between 
the nodes.

Regards,

Bob Peterson
Red Hat Cluster Suite

--
Linux-cluster mailing list
Linux-cluster redhat com
https://www.redhat.com/mailman/listinfo/linux-cluster




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]