[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Linux-cluster] Multi GFS File System



Hi,

I have some problem in mounting a GFS composed by two logical volumes.

My configuration is the following:
- Two servers with Red Hat Enterprise 4 Update 1 (kernel 2.6.9-11.EL);
- Disk Array Dot Hill with HBA Qlogic 2340;
- GFS downloaded from CVS, RHEL4 branch.

I attach my cluster.conf file.

The first attempt I did was with two server and one logical volume, 
and it worked; then I tried with two logical volumes and I can mount 
the partition from one server, while on the other one the "mount" 
command hangs, and I have to reset the machine.

The error message I find on the working server when I try to mount 
the other one is the following:
dlm: <logical_volume_name>: unexpected rcom msgid f/fc6b3 nodeid=2

My doubt is that the sources I download from CVS are not "stable"; 
where can I find a stable release?

Thank you in advance
Ale

Cluster.conf
<?xml version="1.0" ?>
<cluster config_version="6" name="GFS">
<fence_daemon post_fail_delay="0" post_join_delay="3"/>
<clusternodes>
<clusternode name="recorder" votes="1">
<fence/>
</clusternode>
<clusternode name="data_server" votes="1">
<fence/>
</clusternode>
</clusternodes>
<cman expected_votes="1" two_node="1"/>
<fencedevices>
<fencedevice agent="fence_manual" name="Manual_Fencing"/>
</fencedevices>
<rm>
<failoverdomains>
<failoverdomain name="Failover_Domain" ordered="0" restricted="1">
<failoverdomainnode name="recorder" priority="1"/>
<failoverdomainnode name="data_server" priority="1"/>
</failoverdomain>
</failoverdomains>
<resources/>
</rm>
</cluster>



------------------------------------------------------
Francesco ha perso ben 45 Kg! Scopri come! Clicca qui
http://click.libero.it/webnation05dic06




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]