[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Linux-cluster] Multi GFS File System



aleava libero it wrote:
Hi,

I have some problem in mounting a GFS composed by two logical volumes.

My configuration is the following:
- Two servers with Red Hat Enterprise 4 Update 1 (kernel 2.6.9-11.EL);
- Disk Array Dot Hill with HBA Qlogic 2340;
- GFS downloaded from CVS, RHEL4 branch.

I attach my cluster.conf file.

The first attempt I did was with two server and one logical volume, and it worked; then I tried with two logical volumes and I can mount the partition from one server, while on the other one the "mount" command hangs, and I have to reset the machine.

The error message I find on the working server when I try to mount the other one is the following:
dlm: <logical_volume_name>: unexpected rcom msgid f/fc6b3 nodeid=2

My doubt is that the sources I download from CVS are not "stable"; where can I find a stable release?

Thank you in advance
Ale
Hi Ale,

Just some ideas thrown quickly as I head off to a meeting...

The RHEL4 branch in CVS should be the latest and greatest fixes for RHEL4
so it should work properly.  There's also a STABLE branch you can check out
but it should be pretty close to the same code.  Just specify -r STABLE on
your cvs checkout command.

If you're getting odd messages like that, I recommend making sure your
kernel code is the same level as your userland code, and they're the same
on both of your nodes.

Your problem shouldn't be related to the number of logical volumes.
Make sure that you can see all physical volumes from both nodes
by doing something like cat /proc/partitions.  Also, make sure you are
specifying locking_type = 2 in your lvm.conf file.

Regards,

Bob Peterson
Red Hat Cluster Suite


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]