[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Linux-cluster] Problem with more than one partition



Hi,
I try to repost my old question: I want to mount more than one logical volume from our 2 servers (nodes).
The first attempt I did was with two server and one logical volume, and it worked; then I tried with two logical volumes and I can mount the partition from one server, while on the other one the "mount" command hangs, and I have to reset both the machines.

My configuration is the following:
- Two servers with Red Hat Enterprise 4 Update 1 (kernel 2.6.9-11.EL);
- Disk Array Dot Hill with HBA Qlogic 2340;
- GFS downloaded from CVS, RHEL4 branch.

Here, my updated cluster.conf

<?xml version="1.0"?>
<cluster config_version="6" name="GFS">
<fence_daemon post_fail_delay="0" post_join_delay="3"/>
        <clusternodes>
                <clusternode name="recorder" votes="1" nodeid="1">
                        <fence>
                                <method name="1">
                                <device name="Manual_Fencing" nodename="recorder"/>
                                </method>
                        </fence>
                </clusternode>
                <clusternode name="data_server" votes="1" nodeid="2">
                        <fence>
                                <method name="1">
                                <device name="Manual_Fencing" nodename="data_server"/>
                                </method>
                        </fence>
                </clusternode>
        </clusternodes>
        <cman expected_votes="1" two_node="1"/>
        <fencedevices>
                <fencedevice agent="fence_manual" name="Manual_Fencing"/>
        </fencedevices>
        <rm>
                <failoverdomains>
                        <failoverdomain name="Failover_Domain" ordered="0" restricted="1">
                                <failoverdomainnode name="recorder" priority="1"/>
                                <failoverdomainnode name="data_server" priority="1"/>
                        </failoverdomain>
                </failoverdomains>
                <resources/>
        </rm>
</cluster>

Thanks in advance
Ale


------------------------------------------------------
Passa a Infostrada. ADSL e Telefono senza limiti e senza canone Telecom
http://click.libero.it/infostrada19dic06




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]