[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Linux-cluster] Problem with RHEL 4.0 NFS service



Title: Problem with RHEL 4.0 NFS service

I am trying to create an RHEL4.0 NFS service. I have a 2 system cluster.
Cluster.conf file is as below

<?xml version="1.0"?>
<cluster config_version="19" name="dpims_cluster">
        <fence_daemon clean_start="0" post_fail_delay="0" post_join_delay="3"/>
        <clusternodes>
                <clusternode name="pvta09-eth1" votes="1">
                        <fence/>
                </clusternode>
                <clusternode name="pvta10-eth1" votes="1">
                        <fence/>
                </clusternode>
        </clusternodes>
        <cman expected_votes="1" two_node="1"/>
        <fencedevices/>
        <rm>
                <failoverdomains>
                        <failoverdomain name="dpimstst" ordered="0" restricted="1">
                                <failoverdomainnode name="pvta09-eth1" priority="1"/>
                                <failoverdomainnode name="pvta10-eth1" priority="1"/>
                        </failoverdomain>
                </failoverdomains>
                <resources>
                        <fs device="/dev/sdb1" force_unmount="1" fstype="ext3" mountpoint="/disk1" name="dpims" options="rw"/>

                        <ip address="198.1xx.xxx.xxx" monitor_link="1"/>
                        <netfs export="/disk1" force_unmount="1" fstype="nfs4" host="" mountpoint="/disk1" name="dpimstst" options="rw"/>

                        <nfsexport name="disk1"/>
                        <nfsclient name="export" options="rw" target="sysmgr02"/>
                </resources>
                <service autostart="1" domain="dpimstst" name="dpims">
                        <ip ref="198.1xx.xxx.xxx"/>
                        <fs ref="dpims">
                                <nfsexport ref="disk1"/>
                                <nfsclient ref="export"/>
                        </fs>
                </service>
        </rm>
</cluster>



Rgmanager debug log.

Feb  9 17:14:59 pvt10 clurgmgrd[12877]: <notice> Resource Group Manager Starting
Feb  9 17:14:59 pvt10 clurgmgrd[12877]: <info> Loading Service Data
Feb  9 17:14:59 pvt10 clurgmgrd[12877]: <info> Initializing Services
Feb  9 17:14:59 pvt10 clurgmgrd: [12877]: <debug> 198.1xx.xxx.xxx is not configured
Feb  9 17:14:59 pvt10 clurgmgrd: [12877]: <err> No export path specified.
Feb  9 17:14:59 pvt10 clurgmgrd[12877]: <notice> stop on nfsclient "export" returned 2 (invalid argument(s))
Feb  9 17:14:59 pvt10 clurgmgrd[12877]: <info> Services Initialized
Feb  9 17:14:59 pvt10 clurgmgrd[12877]: <info> Logged in SG "usrm::manager"
Feb  9 17:14:59 pvt10 clurgmgrd[12877]: <info> Magma Event: Membership Change
Feb  9 17:14:59 pvt10 clurgmgrd[12877]: <info> State change: Local UP
Feb  9 17:14:59 pvt10 clurgmgrd[12877]: <err> #33: Unable to obtain cluster lock: Operation not permitted


What am I doing wrong ????



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]