[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Linux-cluster] Problem in GFS ...



Hi all,

I m running GFS using GNBD. Like following configuration..

      ____________          ____________
     |Node-2           |        |Node-3          |
     |GNBD client   |        |GNBD client  |
     |____________|        |____________|
           |                                 |
           |                                 |
           |     ____________       |
           |__ |Node-2           |___|
                |GNBD server |
                |____________|

and my configuration file /etc/cluster/cluster.conf looks like...

/*----------------------------
----------------------------------------------------------------------------------*/
<?xml version="1.0"?>
<cluster name="gamma" config_version="1">

<cman two_node="1" expected_votes="1">
</cman>

<clusternodes>
<clusternode name="node1">
        <fence>
                <method name="human">
                        <device name="last_resort" ipaddr="node1"/>
                </method>
        </fence>
</clusternode>

<clusternode name="node2">
        <fence>
                <method name="human">
                        <device name="last_resort" ipaddr="node2"/>
                </method>
        </fence>
</clusternode>
</clusternodes>

<fencedevices>
        <fencedevice name="last_resort" agent="fence_manual"/>
</fencedevices>

</cluster>
/*--------------------------------------------------------------------------------------------------------------*/

I m able to run successfully the GFS on each GNBD client node. But I have following problem...


    1>. If I m creating a file on GNBD client-1, then that file is not visible on
        GNBD client-2. Unless and until I unmount the GFS form GNBD client-1 and
        GNBD client-2, And remounting the exported device.
   
    2>. As u have posted on that article, I swa the /proc/cluster/node on GNBD client-1 and
        GNBD client-2 both look like..
/*--------------------------------------------------------------------------------------------------------------*/  
    [root gnbdcli2 mnt]# cat /proc/cluster/services
    Service          Name                              GID LID State     Code
    Fence Domain:    "default"                           1   2 run       -
    [1]

    DLM Lock Space:  "gfs1"                             24  25 run       -
    [1]

    GFS Mount Group: "gfs1"                             25  26 run       -
    [1]

    [root gnbdcli2 mnt]#
/*--------------------------------------------------------------------------------------------------------------*/  
    They do not reflect both the nodes attached to cluster.


    If any body have any idea where I went wrong then plz help me...
    Waiting to read form u all..
   
   
With Regards
RajSun.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]