[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Linux-cluster] GFS - lost filespace during gfs_grow



Hello,

I have the following problem:

I tried to expand a GFS filesystem from 2 TByte to 3 TByte.

FIrst I expanded successfully the Logical Volume (sits on a FC storage)

Then I tried "gfs_grow -v /export/data/etp".

The last thing it wrote out:

Preparing to write new FS information

After that the load at least on one of the other nodes running the NFS Service 
has gone up (80 - 130), I did not see any big activity on the storage, but 
DLM lock events on the node running gfs_grow.

After some long time (around 20 Minutes) the node running gfs_grow crashed 
with an OOPS ( please see the screenshot at 
http://www.physik.uni-muenchen.de/~klaus.steinberger/crash-dlm.png ).

With df it looks like that only part of the new space was added:

[root etpopt03 ~]# df /export/data/etp
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/mapper/etpdata-etp
                     2427166768 2105093784 322072984  87% /export/data/etp
[root etpopt03 ~]#  

Further gfs_grow commands tell:

[root etpopt03 ~]# gfs_grow -Tv /export/data/etp
Device has grown by less than 100 blocks.... skipping
[root etpopt03 ~]#  

There are 8 journals with standard size (so at most 128 Mbyte should be used 
for the journals), so it looks like around 500 - 600 MByte are missing.
I run Scientific Linux 4.2 (which is similar to RHEL 4.2)

How could I recover the lost space?

Sincerly,
Klaus


-- 
Klaus Steinberger         Maier-Leibnitz Labor
Phone: (+49 89)289 14287  Am Coulombwall 6, D-85748 Garching, Germany
FAX:   (+49 89)289 14280  EMail: Klaus Steinberger Physik Uni-Muenchen DE
URL: http://www.physik.uni-muenchen.de/~k2/

In a world without Walls and Fences, who needs Windows and Gates


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]