[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Linux-cluster] MySQL + RH Cluster Suite + GFS



This is my cluster.conf

-------------

<?xml version="1.0"?>
<cluster config_version="24" name="FON_DB_Cluster">
       <fence_daemon post_fail_delay="0" post_join_delay="30"/>
       <clusternodes>
               <clusternode name="fonessql01" votes="1">
                       <fence>
                               <method name="1">
                                       <device name="iLO-SQL01"/>
                               </method>
                       </fence>
               </clusternode>
               <clusternode name="fonessql02" votes="1">
                       <fence>
                               <method name="1">
                                       <device name="iLO-SQL02"/>
                               </method>
                       </fence>
               </clusternode>
               <clusternode name="fonessql03" votes="1">
                       <fence>
                               <method name="1">
                                       <device name="iLO-SQL03"/>
                               </method>
                       </fence>
               </clusternode>
               <clusternode name="fonessql04" votes="1">
                       <fence>
                               <method name="1">
                                       <device name="iLO-SQL04"/>
                               </method>
                       </fence>
               </clusternode>
       </clusternodes>
       <cman/>
       <fencedevices>
<fencedevice agent="fence_ilo" hostname="fonessql01-ilo" login="Administrator" name="iLO-SQL01" passwd="sadsa"/> <fencedevice agent="fence_ilo" hostname="fonessql02-ilo" login="Administrator" name="iLO-SQL02" passwd="asdad"/> <fencedevice agent="fence_ilo" hostname="fonessql03-ilo" login="Administrator" name="iLO-SQL03" passwd="adsas"/> <fencedevice agent="fence_ilo" hostname="fonessql04-ilo" login="Administrator" name="iLO-SQL04" passwd="adasd"/>
       </fencedevices>
       <rm>
               <failoverdomains>
<failoverdomain name="Radius-Failover-domain" ordered="1" restricted="1"> <failoverdomainnode name="fonessql01" priority="1"/> <failoverdomainnode name="fonessql02" priority="2"/>
                       </failoverdomain>
<failoverdomain name="eShop-Failover-Domain" ordered="1" restricted="1"> <failoverdomainnode name="fonessql02" priority="1"/> <failoverdomainnode name="fonessql01" priority="2"/>
                       </failoverdomain>
<failoverdomain name="WebDB-Failover-Domain" ordered="1" restricted="1"> <failoverdomainnode name="fonessql03" priority="1"/> <failoverdomainnode name="fonessql04" priority="2"/>
                       </failoverdomain>
<failoverdomain name="Billing-Failover-Domain" ordered="1" restricted="1"> <failoverdomainnode name="fonessql04" priority="1"/> <failoverdomainnode name="fonessql03" priority="2"/>
                       </failoverdomain>
               </failoverdomains>
               <resources>
<fs device="/dev/sql01" force_fsck="0" force_unmount="0" fsid="01" fstype="ext3" mountpoint="/mnt/sql01" name="disco-sql01" options="
sync" self_fence="1"/>
<fs device="/dev/sql02" force_fsck="0" force_unmount="0" fsid="02" fstype="ext3" mountpoint="/mnt/sql02" name="disco-sql02" options="
sync" self_fence="1"/>
<fs device="/dev/sql03" force_fsck="0" force_unmount="0" fsid="03" fstype="ext3" mountpoint="/mnt/sql03" name="disco-sql03" options="
sync" self_fence="1"/>
<fs device="/dev/sql04" force_fsck="0" force_unmount="0" fsid="04" fstype="ext3" mountpoint="/mnt/sql04" name="disco-sql04" options="
sync" self_fence="1"/>
                       <ip address="172.17.0.168" monitor_link="1"/>
                       <ip address="172.17.0.169" monitor_link="1"/>
                       <ip address="172.17.0.170" monitor_link="1"/>
                       <ip address="172.17.0.171" monitor_link="1"/>
                       <script file="/etc/init.d/mysql01" name="mysql01"/>
                       <script file="/etc/init.d/mysql02" name="mysql02"/>
                       <script file="/etc/init.d/mysql03" name="mysql03"/>
                       <script file="/etc/init.d/mysql04" name="mysql04"/>
               </resources>
<service autostart="1" domain="Radius-Failover-domain" name="mysql01-Radius" recovery="restart">
                       <fs ref="disco-sql01"/>
                       <ip ref="172.17.0.168"/>
                       <script ref="mysql01"/>
               </service>
<service autostart="1" domain="eShop-Failover-Domain" name="mysql02-eShop-varios" recovery="restart">
                       <fs ref="disco-sql02"/>
                       <ip ref="172.17.0.169"/>
                       <script ref="mysql02"/>
               </service>
<service autostart="1" domain="WebDB-Failover-Domain" name="mysql03-WebDB" recovery="restart">
                       <fs ref="disco-sql03"/>
                       <ip ref="172.17.0.170"/>
                       <script ref="mysql03"/>
               </service>
<service autostart="1" domain="Billing-Failover-Domain" name="mysql04-Billing" recovery="restart">
                       <fs ref="disco-sql04"/>
                       <ip ref="172.17.0.171"/>
                       <script ref="mysql04"/>
               </service>
       </rm>
</cluster>
----------------

and my /etc/hosts

.........................


127.0.0.1 localhost

# Red de Backend
172.17.0.232 fonessql01.es.fon.srv      fonessql01
172.17.0.233 fonessql02.es.fon.srv      fonessql02
172.17.0.234 fonessql03.es.fon.srv      fonessql03
172.17.0.235 fonessql04.es.fon.srv      fonessql04
172.17.0.168 vipsql01.es.fon.srv        vipsql01
172.17.0.169 vipsql02.es.fon.srv        vipsql02
172.17.0.170 vipsql03.es.fon.srv        vipsql03
172.17.0.171 vipsql04.es.fon.srv        vipsql04

# Red de Almacenamiento VLAN 10 (stg)
172.17.4.232 fonessql01.es.fon.stg      fonessql01-stg
172.17.4.233 fonessql02.es.fon.stg      fonessql02-stg
172.17.4.234 fonessql03.es.fon.stg      fonessql03-stg
172.17.4.235 fonessql04.es.fon.stg      fonessql04-stg
172.17.4.244 fonesnas01.es.fon.stg      fonesnas01-stg
172.17.4.245 fonesnas02.es.fon.stg      fonesnas02-stg







----- Original Message ----- From: "Robert Peterson" <rpeterso redhat com>
To: "linux clustering" <linux-cluster redhat com>
Sent: Thursday, June 22, 2006 6:03 PM
Subject: Re: [Linux-cluster] MySQL + RH Cluster Suite + GFS


Eloy Acosta Toscano wrote:
The problem is that when I power off one node ( I mean disable its power supply totally ) to test it, the fencing does not work, on the log I get:

fenced: fencing node "nodename"
fenced: fence "nodename" failed

This will show forerer and the cluster will hang, until the other node join the cluster again. The problem is that, the fenced daemon waits (forever) until the iLO of the dead node back to life.

So my cluster is node reboot/reset fault tolerant, but not totally power off tolerant.
Do you know what I mean?

Can anybody helps me to workaround the problem?

thak U very much
Hi Eloy,

Sounds like maybe there's something wrong in your cluster.conf file.
Perhaps you can post it plus the names of the systems in your cluster
and what kind of fencing you have, and I'll see what I can do.

Regards,

Bob Peterson
Red Hat Cluster Suite

--
Linux-cluster mailing list
Linux-cluster redhat com
https://www.redhat.com/mailman/listinfo/linux-cluster




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]