[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Linux-cluster] Using LABEL in "Device Special File" as a resource



Just FYI... changing cluster.xml by hand works. redhat-config-cluster is simply not allowing the device in it's rules checking. That would be nice to change the code that checks this. I guess I'll file a bugzilla report for it.

And as long as you don't change that device entry, (anything on it), the rest of redhat-config-cluster works. Also in cluster.xml, use LABEL=<mountpoint> with no quotes. I assume if you have a space (IMHO, a bad practice), you could escape it with a \.

Thanks for everyone's input.
Tarun

On Mar 26, 2006, at 6:11 PM, Celso K. Webber wrote:

Hello Tarun,

I had to solve this problem once under RHEL AS v2.1 (first version of Cluster Manager), and it worked perfectly. By that time my problem was that the machines had different internal disk configurations, so they had differente
"/dev/sdXX" names.

Under Cluster Suite v3 I solved this problem by pointing the real devices to
raw devices, and /dev/raw/XXX after that. I don't know if this has
implications on performance, but the systems worked apparently well.

I had once some problems with iSCSI on a IBM Blade Center where the iSCSI volumes changed their /dev/XXX if the machine booted with the USB floppy/cdrom connected (iSCSI dev was /dev/sdb with no USB floppy, but it was recognized as
/dev/sdc if the USB floppy was connected when the machine booted).
Fortunately, it was a regular filesystem (no cluster) and I could use
LABEL=XXX entries in /etc/fstab.

By this time I cannot figure out how could you solve your problem. I imagine that it should not be difficult to write a Perl or Shell script that ran just before the clumanager started, and issuing commands such as "iscsi- ls" it could map a corresponding raw device, or even changing your /etc/ cluster.xml
on the fly and writing it to the quorum using a "cludb" command.

Sorry for not pointing out a better solution, ok?

Regards,

Celso.

On Sun, 26 Mar 2006 18:02:46 -0700, Tarun Reddy wrote
Hmmm....

I guess I never tried to edit cluster.xml by hand. On my system at
least, redhat-config-cluster does not allow the value. I'll try
editing cluster.xml tomorrow and see if that works. Could  you let
me  know if you can get redhat-config-cluster to accept the LABEL
designation? Could it possibly be that my LABEL is "/www" (no quotes)?

Thanks,
Tarun

On Mar 24, 2006, at 10:01 AM, Lon Hohberger wrote:

On Thu, 2006-03-23 at 14:50 -0700, Tarun Reddy wrote:
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Under RHEL3 clustering, I'm trying to mount a partition using the
LABEL since iscsi bindings have a tendency to switch around.

Using Google to search the archives, I found this message:
http://www.redhat.com/archives/linux-cluster/2005-October/
msg00129.html

but this doesn't seem to work with Redhat Clustering on RHEL3. Is
there another way of doing this?

It really should work; it works on my RHEL3 system:

[root magenta root]# e2label /dev/sdd3

[root magenta root]# e2label /dev/sdd3 futon
[root magenta root]# e2label /dev/sdd3
futon
[root magenta root]# vi /etc/cluster.xml
...
    <service checkinterval="10" id="0" name="foo">
      <device id="0" name="LABEL=futon" sharename="">
               <!--   ^- name used to be /dev/sdd3 -->
        <mount forceunmount="yes" fstype="ext3" mountpoint="/mnt/1"
options=""/>
      </device>
      ...
    </service>
...

Starting the service and running the mount command yielded this on my
machine:

[root magenta root]# mount
...
/dev/sdd3 on /mnt/1 type ext3 (rw)
...

Stopping the service causes the mount to go away correctly on my
system.
The label->device resolution has not changed since before the
release of
RHCS3, so there must be something missing that we don't know about.
Note that "LABEL" is case-sensitive, and must be all capital letters,
and that no spaces are allowed.

-- Lon

--
Linux-cluster mailing list
Linux-cluster redhat com
https://www.redhat.com/mailman/listinfo/linux-cluster

--
Linux-cluster mailing list
Linux-cluster redhat com
https://www.redhat.com/mailman/listinfo/linux-cluster


--
Celso K. Webber <celso webbertek com br>
(41) 3284-3035
(41) 8813-1919

--
Linux-cluster mailing list
Linux-cluster redhat com
https://www.redhat.com/mailman/listinfo/linux-cluster


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]