[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Linux-cluster] building GFS-6.1 from SRPMS



Thanks for the response Wendy, but, I couldnt find 
an RPMS dir anywhere under 

ftp.redhat.com:/pub/redhat/linux/enterprise/4/en/RHCS/i386/SRPMS
ftp.redhat.com:/pub/redhat/linux/enterprise/4/en/RHGFS/i386/SRPMS
ftp://ftp.redhat.com/pub/redhat/linux/updates/enterprise/4ES/en/RHGFS/SRPMS/

but I did find..
http://www.redhat.com/archives/linux-cluster/2005-October/msg00076.html

and that got me farther.. right now, im stuck at 

[root tf1 rpms]# sudo rpmbuild -bb /usr/src/redhat/SPECS/GFS-kernel.spec
error: Architecture is not included: i386
[root tf1 rpms]# sudo rpmbuild -bb --target=i686 /usr/src/redhat/SPECS/GFS-kernel.spec
Building target platforms: i686
Building for target i686
error: Failed build dependencies:
        dlm-devel is needed by GFS-kernel-2.6.9-49.1.i686
        dlm-kernheaders is needed by GFS-kernel-2.6.9-49.1.i686
        kernel-devel = 2.6.9-34.EL is needed by GFS-kernel-2.6.9-49.1.i686
        kernel-smp-devel = 2.6.9-34.EL is needed by GFS-kernel-2.6.9-49.1.i686
        kernel-hugemem-devel = 2.6.9-34.EL is needed by GFS-kernel-2.6.9-49.1.i686
        dlm-kernel is needed by GFS-kernel-2.6.9-49.1.i686
        dlm-kernel-smp is needed by GFS-kernel-2.6.9-49.1.i686
        dlm-kernel-hugemem is needed by GFS-kernel-2.6.9-49.1.i686
        dlm-kernheaders >= 2.6.9 is needed by GFS-kernel-2.6.9-49.1.i686
        cman-kernheaders >= 2.6.9 is needed by GFS-kernel-2.6.9-49.1.i686
[root tf1 rpms]# 

so i did 
[root tf1 SPECS]# sudo rpmbuild -bb  --target=i686 cman-kernel.spec 
Building target platforms: i686
Building for target i686
error: Failed build dependencies:
        kernel-smp = 2.6.9-11.EL is needed by cman-kernel-2.6.9-36.0.i686
        kernel-hugemem = 2.6.9-11.EL is needed by cman-kernel-2.6.9-36.0.i686
        kernel-devel = 2.6.9-11.EL is needed by cman-kernel-2.6.9-36.0.i686
        kernel-smp-devel = 2.6.9-11.EL is needed by cman-kernel-2.6.9-36.0.i686
        kernel-hugemem-devel = 2.6.9-11.EL is needed by cman-kernel-2.6.9-36.0.i686
        fake-build-provides is needed by cman-kernel-2.6.9-36.0.i686
[root tf1 SPECS]# 

so I guess I need to edit the spec file and set the extraversion to 
2.6.9-34

and I cant seem to find where to find a redhat version of fake-build-provides..
I have to use the one from CENTOS ? ;)
http://rpm.karan.org/el4/csgfs/SRPMS/fake-build-provides-1.0-20.src.rpm

regards,
Jason


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]