[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Linux-cluster] fence_tool issue



Hello, 

I am working on a shared root gfs cluster and I'm having a problem I can't
seem to figure out... It's just two nodes and I have gfs working fine when
they are both running normally. I am trying to get one of them to fire up
cluster services in an initramfs and pivot root into the gfs filesystem
(which is running already on the other node), and I'm slightly stuck on
fence_tool join. CCSD starts, cman_tool join works fine, and then fence tool
errors out with waiting for ccs connection -111. 

The cluster is quorate, ccs_test fails, but a forced ccs_test works.
cman_tool status tells all and seems to know everything it should.
Networking is fine, including hostnames and all that. One thing I tried was
going with ccsd -I -4 since I think that the ccsd.sock socket did not get
created correctly... But no difference. Stracing fence_tool join doesn't
help much, just basically says that it can't connect to the socket, which I
sort of knew already. Any ideas as to how to verify the ccsd socket or how
to make ccsd -I -4 work so that isn't necessary, or maybe some info on what
fence_tool is trying to do here? I have not blown up all the sources from
the Atix folks yet to see if they have something special going on in there,
but I suppose that's next if no one knows the answer. 
Thanks!
Chris


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]