[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Linux-cluster] problems relocating services



It appears to be running on both nodes:

# cat /proc/cluster/services
Service          Name                              GID LID State     Code
Fence Domain:    "default"                           1   2 run       -
[1 2]

DLM Lock Space:  "Magma"                             3   4 run       -
[1 2]

User:            "usrm::manager"                     2   3 run       -
[1 2]

# ccs_tool lsnode

Cluster name: dades, config_version: 76

Nodename                        Votes Nodeid Iface Fencetype
inf04                              1
inf05                              1

# clustat
Member Status: Quorate

  Member Name                              Status
  ------ ----                              ------
  inf04                                    Online, rgmanager
  inf05                                    Online, Local, rgmanager

  Service Name         Owner (Last)                   State
  ------- ----         ----- ------                   -----
  projectes            inf04                          started
  local                inf04                          started
  mysql                inf05                          started
  postgres             inf05                          started

# ps -fea | grep rg
root      6362     1  0 Oct03 ?        00:00:00 clurgmgrd
root      6364  6362  0 Oct03 ?        00:03:49 clurgmgrd
root     19138  7151  0 09:07 pts/1    00:00:00 tail /var/log/rgmanager
-f -n5000
root      7073  6954  0 20:28 pts/3    00:00:00 grep rg

# ps -fea | grep rg
root      6362     1  0 Oct03 ?        00:00:00 clurgmgrd
root      6364  6362  0 Oct03 ?        00:03:49 clurgmgrd
root     19138  7151  0 09:07 pts/1    00:00:00 tail /var/log/rgmanager
-f -n5000
root      7073  6954  0 20:28 pts/3    00:00:00 grep rg

The same information is displayed on both nodes.

Our version is:

# clustat -v
clustat version 1.9.53
Connected via: CMAN/SM Plugin v1.1.7.1

Any ideas?

Thanks,
Jordi


Lon Hohberger wrote:
> On Wed, 2006-10-04 at 09:51 +0200, Jordi Prats wrote:
>> Thanks,
>> It goes to failed state. Today I've been reloacating services but it 
>> fails to relocate (is not going to failed state):
>>
>> Oct  4 09:07:49 inf04 clurgmgrd[6299]: <notice> Service projectes is stopped
>> Oct  4 09:07:49 inf04 clurgmgrd[6299]: <warning> #70: Attempting to 
>> restart service projectes locally.
>> Oct  4 09:07:49 inf04 clurgmgrd[6299]: <notice> Starting stopped service 
>> projectes
>>
>> On the other node log do not appear anything related to the relocation. 
>> Maybe is a communication problem between nodes?
> 
> It sounds like rgmanager isn't running on the other node or something;
> check /proc/cluster/services? 
> 
> -- Lon
> 
> 
> --
> Linux-cluster mailing list
> Linux-cluster redhat com
> https://www.redhat.com/mailman/listinfo/linux-cluster
> 
> 

-- 
......................................................................
        __
       / /          Jordi Prats Català
 C E / S / C A      Departament de Sistemes
     /_/            Centre de Supercomputació de Catalunya

 Gran Capità, 2-4 (Edifici Nexus) · 08034 Barcelona
 T. 93 205 6464 · F.  93 205 6979 · jprats cesca es
......................................................................
pgp:0x5D0D1321
......................................................................


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]