[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Linux-cluster] CLVM error 6 nodes



Filipe Miranda wrote:
> Hello everybody,
> 
> I have the following environment and I need some help please.
> 3 machines are GULM lock servers (x86 CPUs)
> 3 machines are ORACLE RAC nodes that will use GFS (x86_64 CPUs)
> Only the RAC nodes have access to the shared storage.
> 
> Using Red Hat Enterprise Linux 4.3, Red Hat Cluster Suite Update4 and
> GFS 6.1 Update3
> 
> I setup the RHEL4 plus RHCS and things are just fine. I edited the
> cluster.conf and add the follwing tag to the lock servers members so
> they wont need access to the shared storage: "clvmd=0"  Then I installed
> the CLVM package on all nodes.
> 
> So far so good I created my Physical Volumes then I created my Volume Group.
> The problem is: When I try to create the Logical Volume I get the
> follwing error:
> 
> [root rac-node1 ~]# lvcreate -L 1G -n lv01 vg01
>   Found duplicate PV o2Xf8uUmskTL5fiVQAgY0nJ1ZJSMA9U3: using /dev/sds1
> not /dev/emcpowerb1
>   Found duplicate PV 3yduFLdX3FWPWWMb9lIbtBf3JIPjYnHF: using
> /dev/emcpowerc1 not /dev/sdr1
>   Found duplicate PV Kyha3qI6nVE4odg77UXf7igS3FenGJNn: using /dev/sdd1
> not /dev/emcpowerq1
>   Found duplicate PV WS1LyhqQ8HaE2fIuSnXNd5sgTRtNzNAJ: using /dev/sdt1
> not /dev/emcpowera1
>   Found duplicate PV DuBJ7dZsS3PIO7n5U6hINxPkWorZDzvx: using
> /dev/emcpowerd1 not /dev/sdq1
>   Found duplicate PV ZECZzAtbA0e9pFbl9oL0lZg4q7fkS5x4: using /dev/sdk1
> not /dev/emcpowerj1
>   Found duplicate PV bnVVmL6WhS2mesnOFUkT4fEfR0cFhybD: using
> /dev/emcpowerk1 not /dev/sdj1
>   Found duplicate PV XyXrg2zdxxMS5jo03f9I4QYtGM3ILLGV: using /dev/sdl1
> not /dev/emcpoweri1
>   Found duplicate PV SLE5v2eTD7cJlpRUDGG35xfXkRbW86i1: using
> /dev/emcpowerl1 not /dev/sdi1
>   Found duplicate PV acGyUd2wX7FnOF94Cbt0ombp10iUWMSf: using /dev/sdm1
> not /dev/emcpowerh1
>   Found duplicate PV ll8eNZ0JRh9katV0eui4BcxSc6HBggSI: using
> /dev/emcpowerm1 not /dev/sdh1
>   Found duplicate PV ptGubq8R16LxywZ458P7ebmdG3Fq2aJo: using /dev/sdn1
> not /dev/emcpowerg1
>   Found duplicate PV PLQ3uON7pYe7nY16gRmAP94WBaEydRwf: using
> /dev/emcpowern1 not /dev/sdg1
>   Found duplicate PV PsVYTeKNy6EcqWYbJwQ4KEbPp2Q8HjWv: using /dev/sdo1
> not /dev/emcpowerf1
>   Found duplicate PV hvekbzDAltJ3t23QveOMz1axfhj9Mp2j: using
> /dev/emcpowero1 not /dev/sdf1
>   Found duplicate PV 5OhUbKbZLW5bTc3tpJeU4YlH0dTttJHF: using /dev/sdp1
> not /dev/emcpowere1
>   Found duplicate PV dFtPhq6pkwFdl41NTrAguAEFB3601CTb: using
> /dev/emcpowerp1 not /dev/sde1
>   Error locking on node rac-node1: Internal lvm error, check syslog
>   Error locking on node UNKNOWN [0.0.ffff0000.dfc0800a]: Internal lvm
> error, check syslog
>   Error locking on node lock-server1: Internal lvm error, check syslog
>   Error locking on node lock-server2: Internal lvm error, check syslog
>   Error locking on node lock-server3: Internal lvm error, check syslog
>   Failed to activate new LV.
> 
You need to adjust the filters in /etc/lvm/lvm.conf to exclude the /dev/sda
devices

-- 

patrick


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]