[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Linux-cluster] Problems with failover and services

Jonathan Daniels wrote:
Hi Linux Clusterers,

I have set up the following cluster environment:

2 x HP DL385, with RedHat EL4 Update 3. These are the clustered nodes
RedHat Cluster Suite 4 on each node
Apache 2.2.2 on each node
A dummy daemon on each node

Initial problem:

RHEL4 U3 kernel version 2.6.9-34
CMan kernel/headers 2.6.9-43.8

I created a simple 2 node cluster running Apache httpd server. When it started up as normal the virtual IP was in place and the apache daemon was running on the 'owning' server. However whenever I failed over (by shutting down network services), the floating IP doesn't get assigned to the standby server, and the apache daemon never starts on that standby server.

I was also having deadlocks between CMan and RGManager and found that this was due to a known and fixed bug in RHEL4U3 and Cman so I upgraded them to the following:

RHEL4 U3 kernel version 2.6.9-34.0.1
CMan kernel/headers 2.6.9-43.8.3

Now I start up the "system-cluster-config" and see no services at all. I also removed GFS but I have known RHCS to run without GFS, and in any case the two apache servers and dummy daemons do not share storage - I simply want to perform the failover initially.

Anyone have any workarounds?

Many thanks,

Linux-cluster mailing list
Linux-cluster redhat com

Hi Jon,

You may also be another victim of the init-scripts-not-returning-zero thing.
See: http://sources.redhat.com/cluster/faq.html#rgm_wontrestart


Bob Peterson
Red Hat Cluster Suite

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]