[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Linux-cluster] Samba share resource fails to start after upgrade to Cluster Suite 4U4



Lon Hohberger wrote:

On Fri, 2006-10-20 at 16:47 +0200, Cosimo Streppone wrote:

I'm experiencing a problem with a 2 node cluster just upgraded
(this morning) to current RHEL 4U4 and CS.

Could you post your service config?

Here it is, assuming you're talking about cluster.conf.
Now smb share has been temporarily excluded from service because
of these problems.
Before that, I "attached" it as a "shared resource" to my service.

--
Cosimo

<?xml version="1.0"?>
<cluster config_version="132" name="Slim2K">
	<fence_daemon post_fail_delay="0" post_join_delay="3"/>
	<clusternodes>
		<clusternode name="clu4-1" votes="1">
			<fence>
				<method name="1">
					<device name="clu4-1_iLO"/>
				</method>
			</fence>
		</clusternode>
		<clusternode name="clu4-2" votes="1">
			<fence>
				<method name="1">
					<device name="clu4-2_iLO"/>
				</method>
			</fence>
		</clusternode>
	</clusternodes>
	<fencedevices>
		<fencedevice agent="fence_ilo" hostname="10.1.1.198" login="iwadmin" name="clu4-1_iLO" passwd="passwd"/>
		<fencedevice agent="fence_ilo" hostname="10.1.1.199" login="iwadmin" name="clu4-2_iLO" passwd="passwd"/>
	</fencedevices>
	<rm>
		<failoverdomains>
			<failoverdomain name="Slim2k" ordered="1" restricted="1">
				<failoverdomainnode name="clu4-2" priority="1"/>
				<failoverdomainnode name="clu4-1" priority="1"/>
			</failoverdomain>
		</failoverdomains>
		<resources>
			<ip address="10.1.1.200" monitor_link="1"/>
			<fs device="/dev/mapper/mpath0p1" force_fsck="0" force_unmount="0" fsid="4275" fstype="ext2" mountpoint="/mnt/san" name="Slim2k disk" options="noatime,nodiratime" self_fence="1"/>
			<smb name="//share/exportdb" workgroup="WORKGROUP"/>
			<script file="/etc/rc.d/init.d/smb" name="Samba"/>
			<script file="/etc/rc.d/init.d/xinetd" name="Xinetd"/>
			<script file="/etc/rc.d/init.d/queueManager" name="Slim2k QueueManager"/>
			<script file="/etc/rc.d/init.d/httpd" name="Apache"/>
			<script file="/etc/rc.d/init.d/postgresql" name="Postgres"/>
			<script file="/etc/rc.d/init.d/crond" name="Cron"/>
			<script file="/etc/rc.d/init.d/vtund" name="Vtund"/>
		</resources>
		<service autostart="1" domain="Slim2k" exclusive="1" name="Slim2k">
			<ip ref="10.1.1.200"/>
			<script ref="Xinetd"/>
			<script ref="Samba"/>
			<script ref="Apache"/>
			<script ref="Postgres"/>
			<fs ref="Slim2k disk"/>
			<script ref="Slim2k QueueManager"/>
			<script ref="Cron"/>
			<script ref="Vtund"/>
		</service>
	</rm>
	<cman expected_votes="1" two_node="1"/>
</cluster>

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]