[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Linux-cluster] Clurmtabd needs to be run manually?



On Wed, 2006-09-20 at 16:45 -0700, Rick Rodgers wrote:
> When I start clumanager I notice that clumrmtabd does not start up.
> The man
> page says the service manager daemon will automatically start is for
> each mount 
> point. But this does not seem to happen. 
> 
> I can start it manually. Does anyone know if this is the expected
> behavior? Is it accepatable to manually start it? Below is my
> cluster.xml file.


>   <services>
>     <service checkinterval="5" failoverdomain="Service Nodes" id="0"
> name="service-core" userscript="/etc/init.d/service-core">
>       <service_ipaddresses>
>         <service_ipaddress broadcast="" id="0"
> ipaddress="10.20.70.104" netmask="255.255.255.0"/>
>       </service_ipaddresses>
>       <device id="0" name="LABEL=/service4" sharename="">
>         <mount forceunmount="yes" fstype="ext3" mountpoint="/service"
> options=""/>
>       </device>
>     </service>
>   </services>

It looks like there is no clumanager-managed NFS component to the
service, which is why it's not being started.  If you're not running
NFS, then you don't need clurmtabd.

You can start it manually, or you can tweak the scripts for
your /service mountpoint and make it start if you need to.  The easiest
thing to do is just add a dummy export entry to the service.

-- Lon



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]