[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: AW: [Linux-cluster] system-config-cluster doesn't see cluster



Hi,

thanks. It worked...

Nuno Fernandes

On Saturday 31 March 2007 17:38:22 Hell, Robert wrote:
> Hi,
>
> s-c-cluster uses cman_tool to determine if the on which it is started is a
> cluster member and to read out node and service state. The problem is that
> s-c-cluster uses /sbin/cman_tool but cman_tool is installed in
> /usr/sbin/cman_tool.
>
> Just try: ln -s /usr/sbin/cman_tool /sbin/cman_tool on every node and
> everything will work fine.
>
> See also bugzilla #233621
> (https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=233621
> <https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=233621> ) Also be
> aware of this bugzilla when using the management tab of
> system-config-cluster: #233633
> (https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=233633)
>
> Kind Regards
> Robert
>
> Ing. Robert Hell
> Fabasoft R&D Software GmbH & Co KG
> Honauerstrasse 4
> 4020 Linz
> Austria - Europe
>
> ________________________________
>
> Von: linux-cluster-bounces redhat com im Auftrag von Nuno Fernandes
> Gesendet: Sa 31.03.2007 13:50
> An: linux-cluster
> Betreff: [Linux-cluster] system-config-cluster doesn't see cluster
>
>
>
> Hi,
>
> I've created a cluster using system-config-cluster
> I'm using rhel5 with kernel 2.6.18-8.el5
>
> # uname -a
> Linux xen2.dc.server.pt 2.6.18-8.el5 #1 SMP Fri Jan 26 14:15:14 EST 2007
> x86_64 x86_64 x86_64 GNU/Linux
>
> Apearently everything seems ok:
>
> # clustat
> Member Status: Quorate
>
>   Member Name                        ID   Status
>   ------ ----                        ---- ------
>   xen1.dc.server.pt                      1 Online
>   xen2.dc.server.pt                      2 Online, Local
>   xen3.dc.server.pt                      3 Online
>
> But when i start system-config-cluster in one of the members it reports:
>
> "Because this node is not currently part of a cluster, the management tab
> for this application is not available."
>
> The server where i'm executing system-config-cluster is xen1.dc.server.pt.
> Why does it reports that its not a member of the cluster?
>
> [root xen1 ~]# cman_tool status
> Version: 6.0.1
> Config Version: 3
> Cluster Name: clt_server
> Cluster Id: 52751
> Cluster Member: Yes
> Cluster Generation: 12
> Membership state: Cluster-Member
> Nodes: 3
> Expected votes: 3
> Total votes: 3
> Quorum: 2
> Active subsystems: 7
> Flags:
> Ports Bound: 0 11
> Node name: xen1.dc.server.pt
> Node ID: 1
> Multicast addresses: 239.192.206.221
> Node addresses: 172.16.40.107
>
> I've made several clusters back in rhel4 whithout any problems. I've
> reinstalled the servers twice to make sure that it wasn't any problem, so,
> i'm able to reproduce the problem everytime.
>
> Any info?
>
> Thanks
> Nuno Fernandes
> --
> Nuno Pais Fernandes
> Cisco Certified Network Associate
> Oracle Certified Professional
> Eurotux Informatica S.A.
> Tel: +351 253257395
> Fax: +351 253257396
>
> --
> Linux-cluster mailing list
> Linux-cluster redhat com
> https://www.redhat.com/mailman/listinfo/linux-cluster
> <https://192.84.221.201/https/0/www.redhat.com/mailman/listinfo/linux-clust
>er>



-- 
Nuno Pais Fernandes
Cisco Certified Network Associate
Oracle Certified Professional
Eurotux Informatica S.A.
Tel: +351 253257395
Fax: +351 253257396

Attachment: pgpUWSdbdanrG.pgp
Description: PGP signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]