[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Linux-cluster] fence option problem



Marco Minato wrote:

James Parsons ha scritto:

Marco Minato wrote:

James Parsons ha scritto:

Marco Minato wrote:

Hi all guys,

I've some problem to change the default action of a fence action.
I want the cluster to shutdown the not-responding node instead of reboot it.

I've tried to change the default action of the script "fence_apc" but it seems not to be used from the cluster (as I've renemed it and still working).

I'm interested to change the action on the plugin.. How is it possible?

Thanks.

--
Linux-cluster mailing list
Linux-cluster redhat com
https://www.redhat.com/mailman/listinfo/linux-cluster



In the conf file, in the <device> section, under the clusternode, where you are specifying the port (outlet) # on your apc switch, include an attribute stating option="Off", and the node should stay off when fenced. If it does not, then you need to look towards the bios settings on the system.

If you want, XXX out your passwords for your devices and send along your conf file. I will help you add the attribute.

-Jim

--
Linux-cluster mailing list
Linux-cluster redhat com
https://www.redhat.com/mailman/listinfo/linux-cluster


yes.. but all the times that I modify d configuration through system-config-cluster the system change the "option" statement.. I was searching another way to do it.. Now I've changed from bios the conf and it's working. it's good for me.


Marco - are you saying that when you added the option="Off" to the conf file by hand and then started system-config-cluster, that the option="Off" attribute was removed? That would be a bug :)

Which version of cluster suite and s-c-cluster are you running??

Thanks,

-J



--
Linux-cluster mailing list
Linux-cluster redhat com
https://www.redhat.com/mailman/listinfo/linux-cluster




--
Linux-cluster mailing list
Linux-cluster redhat com
https://www.redhat.com/mailman/listinfo/linux-cluster


Look. I've modified now cluster.conf as down

               <clusternode name="nodo1" votes="1">
                       <fence>
                               <method name="1">
<device name="APC_fence" port="1" switch="10.0.0.10" option="Off"/>
                               </method>
                       </fence>
               </clusternode>
               <clusternode name="nodo2" votes="1">
                       <fence>
                               <method name="1">
<device name="APC_fence" port="2" switch="10.0.0.10" option="Off"/>
                               </method>
                       </fence>
               </clusternode>

wondering option statement is ok..

I've modified <device> part as you said, upgrade the config_version and copied the conf file in nodes and restarted cluster. now in s-c-c i've no per-node fence device configured.. if I click on "send to cluster" icon the system update
the configuration as down:

<clusternode name="nodo1" votes="1">
                       <fence>
                               <method name="1"/>
                       </fence>
               </clusternode>
               <clusternode name="nodo2" votes="1">
                       <fence>
                               <method name="1"/>
                       </fence>
               </clusternode>

No fence device!! I've tried to use ccs_tool for propagating the config file with the same result.. What I'm doing bad?? :)

1) The 'switch' parameter (which you have set to "10.0.0.10") is used only when you are using ganged apc switches, that is, multiple daisy-chained switches. Leave that parameter off...and it is def not supposed to be a dotted quad :) 2) Do you have a <fencedevices> section in your conf file? There should be something that looks like this:
<fencedevices>
 <fencedevice type="fence_apc" login="xxx" passwd="xxx" name="APC_fence"/>
</fencedevices>

It is possible that if the fencedevices block is missing, then the ui might be saying to itself, 'these fence instances are useless' and not including them. I will have to look at the code...but first, I want to get your cluster running - and you will need to specify fencedevices in order for that to happen.

-J


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]