[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Linux-cluster] dependency problem when install cman-kernel-2.6.9-50.2.src.rpm



You should be able to install these packages via RHN and up2date.


darkblue wrote:
> When I installing cman-kernel, there is a dependency problem.
> [root rh4-clus1 rhcs4]# rpm -iv cman-kernel-2.6.9-59.2.src.rpm
> [root rh4-clus1 SPECS]# rpmbuild -ba --target=i686 cman-kernel.spec
> Building target platforms: i686
> Building for target i686
> error: Failed build dependencies:
>         kernel-devel = 2.6.9-55.EL is needed by cman-kernel-2.6.9-50.2.i686
>         kernel-smp-devel = 2.6.9-55.EL is needed by cman-kernel-2.6.9-50.2.i686
>         kernel-hugemem-devel = 2.6.9-55.EL is needed by
> cman-kernel-2.6.9-50.2.i686
>         kernel-xenU-devel = 2.6.9-55.EL is needed by cman-kernel-2.6.9-50.2.i686
> [root rh4-clus1 SPECS]# uname -a
> Linux rh4-clus1.darkblue.com 2.6.9-55.EL #1 Fri Apr 20 16:35:59 EDT
> 2007 i686 i686 i386 GNU/Linux
>
> I am curious that I am using the 2.6.9-55 kernel, why there is still a
> dependency problem? and How to fix it?
>   


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]