[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Linux-cluster] Re: First steps with CS5/RHEL5 (contd.)



Hi
Some new stuff : I've added the "return" just at the
begining of check_xml function in CommandHandler.py
and now GUI works fine with my cluster.conf .
But even when saving again as a new cluster.conf
I always got the same error about local node name
not found in cluster.conf.

Alain

Hi

Thanks Patrick for information.

And sorry about first message :
cman not started: CCS does not have a nodeid for this node, run 'ccs_tool
> addnodeids' to fix /usr/sbin/cman_tool: aisexec daemon didn't start
It was effectively clear enough and I had fixed the problem, I just mismatch
the error message when copy/paste in email.
My problem was effectively in the second email, meaning :
> cman not started: Can't find local node name in cluster.conf
> /usr/sbin/cman_tool: aisexec daemon didn't start
>                  [FAILED]

I tried "cman_tool join -d " as you recommanded, it returns :
[root am2 log]# cman_tool join -d
waiting for aisexec to start
[MAIN ] AIS Executive Service RELEASE 'subrev 1358 version 0.80.3'
cman not started: Can't find local node name in cluster.conf
cman_tool: aisexec daemon didn't start
[root am2 log]# [MAIN ] Copyright (C) 2002-2006 MontaVista Software, Inc and
contributors.
[MAIN ] Copyright (C) 2006 Red Hat, Inc.
[MAIN ] AIS Executive Service: started and ready to provide service.
[MAIN ] local node name "am2" not found in cluster.conf
[MAIN ] Error reading CCS info, cannot start
[MAIN ]
[MAIN ] AIS Executive exiting (-9).

And when I launch the system-config-cluster GUI , I got errors :
Relax-NG validity error : Extra element rm in interleave
/etc/cluster/cluster.conf:25: element rm: Relax-NG validity error : Element
cluster failed to validate content
/etc/cluster/cluster.conf fails to validate

My cluster.conf is :
==================
<?xml version="1.0"?>
<cluster config_version="1" name="TEST">
        <fence_daemon clean_start="1" post_fail_delay="0" post_join_delay="3"/>
        <clusternodes>
                <clusternode name="am1" nodeid="1" votes="1">
                        <fence>
                                <method name="1">
                                        <device name="am1fence" option="reboot"/>
                                </method>
                        </fence>
                </clusternode>
                <clusternode name="am2" nodeid="2" votes="1">
                        <fence>
                                <method name="1">
                                        <device name="am2fence" option="reboot"/>
                                </method>
                        </fence>
                </clusternode>
        </clusternodes>
        <cman expected_votes="1" two_node="1"/>
        <fencedevices>
                <fencedevice agent="fence_ipmilan" ipaddr="162.29.1.116"
login="administrator" name="am1fence" passwd="administrator"/>
                <fencedevice agent="fence_ipmilan" ipaddr="162.29.1.117"
login="administrator" name="am2fence" passwd="administrator"/>
        </fencedevices>
        <rm>
                <failoverdomains>
                        <failoverdomain name="testHA" ordered="0" restricted="0">
                                <failoverdomainnode name="am1" priority="1"/>
                                <failoverdomainnode name="am2" priority="1"/>
                        </failoverdomain>
                </failoverdomains>
                <service domain="testHA" name="test_am1" autostart="0"
checkinterval="60">
                        <script file="/usr/sbin/test_am1" name="test_am1"/>
                </service>
                <service domain="testHA" name="test_am2" autostart="0"
checkinterval="60">
                        <script file="/usr/sbin/test_am2" name="test_am2"/>
                </service>
        </rm>
</cluster>

Thanks for your help.
Alain


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]