[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Linux-cluster] multipathd/ lvm.static error



On Thu, Jan 11, 2007 at 11:08:31AM -0500, Jon Erickson wrote:
> All,
> 
> I'm receiving these two errors on all of the systems I have setup in
> my GFS cluster.
> Even though I receive these errors my systems appear to be functioning
> fine.  The first error makes sense because my local SCSI disk is not
> multipath-ed, however, I do not know how to get rid of it.  The second
> error is confusing to me especially because the system still comes up
> with all of my multipath-ed devices in working order.

Even if you aren't multipathing your local disk, it should have a scsi id.
try manually running

# /sbin/scsi_id -v -g u -s /block/sda

If this fails, hopefully you'll get some debugging information. If this works
correctly, then try running

# /sbin/multipath -v6

and check if you can see this error there. If so, hopefully you'll get some
useful debugging information. Otherwise, you can start multipathd with
debugging

# /sbin/multipathd -v6

And parse through all the stuff you get to see there is any debugging
information there.


> 
> multipathd: error calling out /sbin/scsi_id -g -u -s /block/sda
> 
> lvm.static[6938]: segfault at 0000000000000000 rip 0000000000000000
> rsp 0000007fbfff9388 error 14
> 
> 
> -------------------------------
> uname -r = 2.6.9-42.0.3.ELsmp
> 
> Packages Installed:
> system-config-lvm-1.0.16-1.0
> lvm2-cluster-2.02.06-7.0.RHEL4
> lvm2-2.02.06-6.0.RHEL4
> device-mapper-multipath-0.4.5-16.1.RHEL4
> GFS-6.1.6-1
> GFS-kernel-smp-2.6.9-60.3
> GFS-kernheaders-2.6.9-60.3
> kernel-smp-2.6.9-42.0.3.EL
> 
> 
> Thanks,
> Jon
> 
> --
> Linux-cluster mailing list
> Linux-cluster redhat com
> https://www.redhat.com/mailman/listinfo/linux-cluster


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]