[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Linux-cluster] Can't get past Segmentation Faults



> If you want to test it, get all your volumes created, shutdown one
> machine, disable it's FC ports and restart it.  Was clvmd barfing
> because of this?  Could it see some, but not all of the devices.

I'll test this once everything is back together.
 
> Would the fix have been as simple as simply reenabling the ports to all
> the machines?  I don't know...

No, I looked at this also. All machines had access. What I did notice was that 
the switch was in a state with flashing ports so I restarted it and all seemed 
to go fine after that.
 
> I can't imagine your storage being trashed by the FC network.  Even if
> the logical volume headers were destroyed, they can be brought back by
> vgcfgrestore.  That would just leave the file systems.  They have

Well, that's where things got weird. It didn't matter what I tried, I would 
get seg faults. I was not able to run ANY tools on the storage other than 
fdisk'ing them to LVM, that's it. Nothing else worked.

> journaling.  So assuming some rouge process didn't mess with the disk,
> they should be able to recover just fine as long as the storage (CLVM
> volumes) are visible.

That's the other funky thing that happened and is why I posted asking if what 
I see from webmin is the same as what I see from the command line. I asked 
that because I was sometimes able to see volumes from one or the other.

Either way though, I was not able to do anything with the volume I would see 
because I would get seg faults. The seg faults ended once I reformatted one of 
the devices, which is one of the one's back on line now.

Mike




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]