[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Linux-cluster] LVM2 from cvs is a no go



On 1/26/07, Bryn M. Reeves <breeves redhat com> wrote:
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Brandon Lamb wrote:
> So I am following the instructions from the usage.txt
>
> I have instaled a 2.6.19.2 kernel with gfs2, dlm, configfs, ipv6 and
> sctp. I installed openais from the svn.osdl.org/openais, i installed
> libvolume_id using udev-104, and i installed cluster from the cvs.
>
> Now I am onto instaling LVM2/CLVM (optional) it says, but it will not
> compile. Am I missing something? Below is the output from make
>
>

All those errors relate to symbols in the device-mapper library. It
looks like the version installed on your system is too old to build
current CVS.

Grab a later version from http://sourceware.org/dm/ and you should find
the build problems go away. You might also want to look at the
"--with-dm=/path" configure option for LVM2 - that way you can build it
against the latest libdevmapper without replacing whatever version is
installed on your distribution.

Kind regards,

Bryn.

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2.2 (GNU/Linux)
Comment: Using GnuPG with Fedora - http://enigmail.mozdev.org

iD8DBQFFucyD6YSQoMYUY94RAsVnAJwLOGxEuZ1iT5IevzKYjjGzP5YOCgCcD3Dd
1ySTGmGnUupjv1JbiqlpFgk=
=6AZ/
-----END PGP SIGNATURE-----

--
Linux-cluster mailing list
Linux-cluster redhat com
https://www.redhat.com/mailman/listinfo/linux-cluster

Aha! I'll give that a try thanks!


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]