[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Linux-cluster] Debug fencing.




Hi all.

I'm wondering if there is a way to get decent logs about what fenced is trying to do? My machines (centos5) seem to hang at "starting fencing" and the log files aren't showing anything of import.

Any pointers on getting more debugging would be great. Everything seemed to work until I added a third machine and changed the multicast address.

My cluster.conf as follows:

<?xml version="1.0" ?>
<cluster config_version="13" name="XenHosts">
        <fence_daemon post_fail_delay="0" post_join_delay="10"/>
        <clusternodes>
<clusternode name="karma01.sfac.auckland.ac.nz" nodeid="1" votes="1"> <multicast addr="239.193.236.96" interface="eth0"/>
                        <fence>
                                <method name="1">
<device name="Faux_Fence" nodename="karma01.sfac.auckland.ac.nz"/>
                                </method>
                        </fence>
                </clusternode>
<clusternode name="karma02.sfac.auckland.ac.nz" nodeid="2" votes="1"> <multicast addr="239.193.236.96" interface="eth0"/>
                        <fence>
                                <method name="1">
<device name="Faux_Fence" nodename="karma02.sfac.auckland.ac.nz"/>
                                </method>
                        </fence>
                </clusternode>
<clusternode name="xmail01.sfac.auckland.ac.nz" nodeid="3" votes="1"> <multicast addr="239.193.236.96" interface="eth0"/>
                        <fence>
                                <method name="1">
<device name="Faux_Fence" nodename="xmail01.sfac.auckland.ac.nz"/>
                                </method>
                        </fence>
                </clusternode>
        </clusternodes>
        <cman>
                <multicast addr="239.193.236.96"/>
        </cman>
        <fencedevices>
                <fencedevice agent="fence_manual" name="Faux_Fence"/>
        </fencedevices>
        <rm>
                <failoverdomains>
<failoverdomain name="XenVMs" ordered="0" restricted="1"> <failoverdomainnode name="karma01.sfac.auckland.ac.nz" priority="1"/> <failoverdomainnode name="karma02.sfac.auckland.ac.nz" priority="1"/>
                        </failoverdomain>
<failoverdomain name="MailVMs" ordered="1" restricted="0"> <failoverdomainnode name="xmail01.sfac.auckland.ac.nz" priority="1"/> <failoverdomainnode name="karma01.sfac.auckland.ac.nz" priority="2"/> <failoverdomainnode name="karma02.sfac.auckland.ac.nz" priority="2"/>
                        </failoverdomain>
                </failoverdomains>
                <resources>
<clusterfs device="/dev/Xen/Configs" force_unmount="0" fsid="18041" fstype="gfs" mountpoint="/var/xen" name="XenConfigs" options=""/>
                </resources>
        </rm>
</cluster>


--
James Tyson
x87422
9:249:17:2:157:116:227:91:216:65:86:197:99:86:136:192



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]