[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Linux-cluster] make errors for 2.6.19 on fc6



nirmal tom wrote:

hi,
I am running fc6 and my kernel version is 2.6.19-1.2911.fc6.I installed openais succesfully and i thind i dont need to install libvolume_id as i am running fc6,it already contains udev-095-14

i downloaded development version using
cvs -d :pserver:cvs sources redhat com:/cvs/cluster checkout cluster
and now when i run make , it fetches me the error
make -C dlm_controld all
make[2]: Entering directory `/opt/cluster/group/dlm_controld'
gcc -Wall -g -I//usr/include -I../config -idirafter /usr/src/kernels/2.6.19-1.2911.fc6-i686/include/linux -I../../group/lib/ -I../../ccs/lib/ -I../../cman/lib/ -I../include/ -c -o main.o main.c
main.c: In function ‘setup_uevent’:
main.c:188: error: ‘NETLINK_KOBJECT_UEVENT’ undeclared (first use in this function)
main.c:188: error: (Each undeclared identifier is reported only once
main.c:188: error: for each function it appears in.)
make[2]: *** [main.o] Error 1
make[2]: Leaving directory `/opt/cluster/group/dlm_controld'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/opt/cluster/group'
make: *** [all] Error 2

As for stable verion is consent, i got the same error.

   Try...
   # cd /usr/include
   # mv linux linux.old
   # ln -s /usr/src/kernels/2.6.19-1.2911.fc6-i686/include/linux linux
Regards ;-)

Thanks for any response.

regards,
Nirmal Tom.


--
Linux-cluster mailing list
Linux-cluster redhat com
https://www.redhat.com/mailman/listinfo/linux-cluster



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]