[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Linux-cluster] errors while building cluster-1.03.00 with 2.6.18-1.2798.fc6xen



Hello,
I try to build cluster-1.03.00 on x86_64 against a xen tree
(2.6.18-1.2798.fc6xen)

I ran:

./configure --kernel_src=/lib/modules/2.6.18-1.2798.fc6xen/build
And then:
make install

I get these errors:

make[4]: Entering directory `/usr/src/kernels/2.6.18-1.2798.fc6-xen-x86_64'
 CC [M]  /work/src/cluster-1.03.00/gfs-kernel/src/harness/main.o
/work/src/cluster-1.03.00/gfs-kernel/src/harness/main.c:121: error:
expected declaration specifiers or '...' before 'lm_fsdata_t'
/work/src/cluster-1.03.00/gfs-kernel/src/harness/main.c: In function 'lm_mount':
/work/src/cluster-1.03.00/gfs-kernel/src/harness/main.c:162: error:
'fsdata' undeclared (first use in this function)
...
...

Any idea why these errors ?

Regards,
Ian


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]