[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Linux-cluster] GFS mounting problem.



Hello,
I've just updated my two Centos5 nodes, with this update it installed a new kenerl (2.6.18-8.1.4)
and removed kmod-gfs and kmod-gnbd.
But now I can't mount my gfs volumes with the new kernel.

on the dbLV it says error 16 (Device or resource busy)
# mount -t gfs -v /dev/clusterVG/db /cluster/db/
/sbin/mount.gfs: mount /dev/clusterVG/db /cluster/db
/sbin/mount.gfs: parse_opts: opts = "rw"
/sbin/mount.gfs:   clear flag 1 for "rw", flags = 0
/sbin/mount.gfs: parse_opts: flags = 0
/sbin/mount.gfs: parse_opts: extra = ""
/sbin/mount.gfs: parse_opts: hostdata = ""
/sbin/mount.gfs: parse_opts: lockproto = ""
/sbin/mount.gfs: parse_opts: locktable = ""
/sbin/mount.gfs: message to gfs_controld: asking to join mountgroup:
/sbin/mount.gfs: write "join /cluster/db gfs lock_dlm acl002:cluster_db rw /dev/clusterVG/db"
/sbin/mount.gfs: lock_dlm_join: gfs_controld join error: -16
/sbin/mount.gfs: error mounting lockproto lock_dlm

on the other two LVs it says error 19 (No such device)
# mount -t gfs -v /dev/syncaderoVG/web /syncadero/web/
/sbin/mount.gfs: mount /dev/syncaderoVG/web /syncadero/web
/sbin/mount.gfs: parse_opts: opts = "rw"
/sbin/mount.gfs:   clear flag 1 for "rw", flags = 0
/sbin/mount.gfs: parse_opts: flags = 0
/sbin/mount.gfs: parse_opts: extra = ""
/sbin/mount.gfs: parse_opts: hostdata = ""
/sbin/mount.gfs: parse_opts: lockproto = ""
/sbin/mount.gfs: parse_opts: locktable = ""
/sbin/mount.gfs: message to gfs_controld: asking to join mountgroup:
/sbin/mount.gfs: write "join /syncadero/web gfs lock_dlm acl002:cluster_web rw /dev/clusterVG/web"
/sbin/mount.gfs: message from gfs_controld: response to join request:
/sbin/mount.gfs: lock_dlm_join: read "0"
/sbin/mount.gfs: message from gfs_controld: mount options:
/sbin/mount.gfs: lock_dlm_join: read "hostdata=jid=0:id=589825:first=1"
/sbin/mount.gfs: lock_dlm_join: hostdata: "hostdata=jid=0:id=589825:first=1"
/sbin/mount.gfs: lock_dlm_join: extra_plus: "hostdata=jid=0:id=589825:first=1"
/sbin/mount.gfs: mount(2) failed error -1 errno 19
/sbin/mount.gfs: lock_dlm_mount_result: write "mount_result /cluster/web gfs -1"
/sbin/mount.gfs: message to gfs_controld: asking to leave mountgroup:
/sbin/mount.gfs: lock_dlm_leave: write "leave /cluster/web gfs 19"
/sbin/mount.gfs: message from gfs_controld: response to leave request:
/sbin/mount.gfs: lock_dlm_leave: read "0"
/sbin/mount.gfs: error 19 mounting /dev/clusterVG/web on /cluster/web

everything worked before the update.

I found this link http://www.centos.org/modules/newbb/viewtopic.php?topic_id=7968,
but I didn't find it useful.

Would appreciate any ideas.

Thanks in advance,
Dan


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]