[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Linux-cluster] Problem lock_dlm_join gfs_controld join error -16



Hi there,

there is a main difference when I use "cman_tool services". On the
working node:

[root node2 ~]# cman_tool services
type             level name          id       state
fence            0     default       00010001 none
[1 2]
dlm              1     clvmd         00020001 none
[1 2]
dlm              1     CfusterGFS01  00040001 none
[1 2]
dlm              1     ClusterGFS02  00060001 none
[2]
dlm              1     rgmanager     00070001 none
[1 2]
gfs              2     CfusterGFS01  00030001 none
[1 2]
gfs              2     ClusterGFS02  00050001 none
[2]


On the non-working node:
[root node1 ~]# cman_tool services
type             level name          id       state
fence            0     default       00010001 none
[1 2]
dlm              1     clvmd         00020001 none
[1 2]
dlm              1     CfusterGFS01  00040001 none
[1 2]
dlm              1     rgmanager     00070001 none
[1 2]
gfs              2     CfusterGFS01  00030001 none
[1 2]

Well - but  CfusterGFS01 is not mounted on node1. Seems to me like dlm
(or gfs) is thinking that the filesystem is mounted. But it isn't. Has
anybody an idea how to kick it out?

Thx - Martin

On Mon, 2008-04-21 at 06:48 -0700, Leo Pleiman wrote:
> I believe you will find that the nodes haven't properly joined the
> fence domain. Try the following commands:
> 
> ccs_tool lsfence
> ccs_tool lsnode
> cman_tool status
> cman_tool services
> 
> ...also check /var/log/messages
>  
> --Leo
> 
> 
> ----- Original Message ----
> From: Martin Fuerstenau <martin fuerstenau oce com>
> To: linux-cluster redhat com
> Sent: Monday, April 21, 2008 9:39:42 AM
> Subject: [Linux-cluster] Problem lock_dlm_join gfs_controld join error
> -16
> 
> Hi there,
> 
> I am running a 2 node cluster with Centos 5. After a clusterswitch
> last weekend I am not able to mount one of the filesystems on both
> nodes. Read a lot last hours in the internet but unfortunately I found
> neither a solution nor a hint where the error is.
> 
> When I try 
> 
> mount -t gfs /dev/VolGroup01/ClusterVol01 /mnt/tmp
> 
> 
> I get 
> 
> /sbin/mount.gfs: lock_dlm_join: gfs_controld join error: -16
> /sbin/mount.gfs: error mounting lockproto lock_dlm
> 
> Has anybody an idea where to look for or what to do?
> 
> Thanx, Martin 

> 
> 
> 
> --
> Linux-cluster mailing list
> Linux-cluster redhat com
> https://www.redhat.com/mailman/listinfo/linux-cluster

Visit Oce at drupa! Register online now: <http://drupa.oce.com>

This message and attachment(s) are intended solely for use by the addressee and may contain information that is privileged, confidential or otherwise exempt from disclosure under applicable law.

If you are not the intended recipient or agent thereof responsible for delivering this message to the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited.

If you have received this communication in error, please notify the sender immediately by telephone and with a 'reply' message.

Thank you for your co-operation.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]