[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Linux-cluster] Node Offline



I change the service to xvm.

I wnat that vm admin start at vserver1 and intranetteste at vserver2.

[root vserver1 ~]# clustat
Member Status: Quorate

  Member Name                        ID   Status
  ------ ----                        ---- ------
  vserver1.uniube.br                    1 Online, Local, rgmanager
  vserver2.uniube.br                    2 Offline

  Service Name         Owner (Last)                   State
  ------- ----         ----- ------                   -----
  vm:admin             (none)                         disabled
  vm:intranetteste     (none)                         disabled


[root vserver2 ~]# clustat
Member Status: Quorate

  Member Name                        ID   Status
  ------ ----                        ---- ------
  vserver1.uniube.br                    1 Offline
  vserver2.uniube.br                    2 Online, Local, rgmanager

  Service Name         Owner (Last)                   State
  ------- ----         ----- ------                   -----
  vm:admin             (none)                         disabled
  vm:intranetteste     (none)                         disabled


My cluster.conf

<?xml version="1.0" ?>
<cluster config_version="39" name="cluster1">
  <fence_daemon clean_start="0" post_fail_delay="0"
post_join_delay="30"/>
  <fence_xvmd/>
  <totem token="21000"/>
  <clusternodes>
    <clusternode name="vserver1.uniube.br" nodeid="1" votes="1">
      <fence>
        <method name="1">
          <device domain="admin" name="xvm"/>
        </method>
      </fence>
    </clusternode>
    <clusternode name="vserver2.uniube.br" nodeid="2" votes="1">
      <fence>
        <method name="1">
          <device domain="intranetteste" name="xvm"/>
        </method>
      </fence>
    </clusternode>
  </clusternodes>
  <cman expected_votes="1" two_node="1"/>
  <fencedevices>
    <fencedevice agent="fence_xvm" name="xvm"/>
  </fencedevices>
  <rm>
    <failoverdomains/>
    <resources/>
    <vm autostart="0" name="admin" path="/etc/xen"/>
    <vm autostart="0" name="intranetteste" path="/etc/xen"/>
  </rm>
</cluster>

The vserver1 start ok.

But when I start the vserver2 node then I have a problem.

In my log messages:

Feb 11 14:18:43 vserver2 openais[6643]: [CLM  ] CLM CONFIGURATION CHANGE
Feb 11 14:18:43 vserver2 openais[6643]: [CLM  ] New Configuration:
Feb 11 14:18:43 vserver2 openais[6643]: [CLM  ]         r(0)
ip(192.168.200.201)
Feb 11 14:18:43 vserver2 openais[6643]: [CLM  ] Members Left:
Feb 11 14:18:43 vserver2 openais[6643]: [CLM  ] Members Joined:
Feb 11 14:18:43 vserver2 openais[6643]: [CLM  ] CLM CONFIGURATION CHANGE
Feb 11 14:18:43 vserver2 openais[6643]: [CLM  ] New Configuration:
Feb 11 14:18:43 vserver2 openais[6643]: [CLM  ]         r(0)
ip(192.168.200.200)
Feb 11 14:18:43 vserver2 openais[6643]: [CLM  ]         r(0)
ip(192.168.200.201)
Feb 11 14:18:43 vserver2 openais[6643]: [CLM  ] Members Left:
Feb 11 14:18:44 vserver2 openais[6643]: [CLM  ] Members Joined:
Feb 11 14:18:44 vserver2 openais[6643]: [CLM  ]         r(0)
ip(192.168.200.200)
Feb 11 14:18:44 vserver2 openais[6643]: [SYNC ] This node is within the
primary component and will provide service.
Feb 11 14:18:44 vserver2 openais[6643]: [TOTEM] entering OPERATIONAL
state.
Feb 11 14:18:44 vserver2 openais[6643]: [TOTEM] Retransmit List: 1

after :

Feb 11 14:19:24 vserver2 openais[6643]: [CLM  ] CLM CONFIGURATION CHANGE
Feb 11 14:19:24 vserver2 openais[6643]: [CLM  ] New Configuration:
Feb 11 14:19:24 vserver2 openais[6643]: [CLM  ]         r(0)
ip(192.168.200.201)
Feb 11 14:19:24 vserver2 openais[6643]: [CLM  ] Members Left:
Feb 11 14:19:24 vserver2 openais[6643]: [CLM  ]         r(0)
ip(192.168.200.200)
Feb 11 14:19:24 vserver2 openais[6643]: [CLM  ] Members Joined:
Feb 11 14:19:24 vserver2 openais[6643]: [CLM  ] CLM CONFIGURATION CHANGE
Feb 11 14:19:24 vserver2 openais[6643]: [CLM  ] New Configuration:
Feb 11 14:19:24 vserver2 openais[6643]: [CLM  ]         r(0)
ip(192.168.200.201)
Feb 11 14:19:24 vserver2 openais[6643]: [CLM  ] Members Left:
Feb 11 14:19:24 vserver2 openais[6643]: [CLM  ] Members Joined:
Feb 11 14:19:24 vserver2 openais[6643]: [SYNC ] This node is within the
primary component and will provide service.
Feb 11 14:19:24 vserver2 openais[6643]: [TOTEM] entering OPERATIONAL
state.

and the cluster of node2 crash:

Feb 11 14:20:48 vserver2 openais[6643]: [CLM  ] CLM CONFIGURATION CHANGE
Feb 11 14:20:48 vserver2 openais[6643]: [CLM  ] New Configuration:
Feb 11 14:20:48 vserver2 openais[6643]: [CLM  ]         r(0)
ip(192.168.200.201)
Feb 11 14:20:48 vserver2 openais[6643]: [CLM  ] Members Left:
Feb 11 14:20:48 vserver2 openais[6643]: [CLM  ] Members Joined:
Feb 11 14:20:48 vserver2 openais[6643]: [CLM  ] CLM CONFIGURATION CHANGE
Feb 11 14:20:48 vserver2 openais[6643]: [CLM  ] New Configuration:
Feb 11 14:20:48 vserver2 openais[6643]: [CLM  ]         r(0)
ip(192.168.200.200)
Feb 11 14:20:48 vserver2 openais[6643]: [CLM  ]         r(0)
ip(192.168.200.201)
Feb 11 14:20:49 vserver2 openais[6643]: [CLM  ] Members Left:
Feb 11 14:20:49 vserver2 openais[6643]: [CLM  ] Members Joined:
Feb 11 14:20:49 vserver2 openais[6643]: [CLM  ]         r(0)
ip(192.168.200.200)
Feb 11 14:20:49 vserver2 openais[6643]: [SYNC ] This node is within the
primary component and will provide service.
Feb 11 14:20:49 vserver2 openais[6643]: [TOTEM] entering OPERATIONAL
state.
Feb 11 14:20:49 vserver2 openais[6643]: [MAIN ] Killing node
vserver1.uniube.br because it has rejoined the cluster without cman_tool
join
Feb 11 14:20:49 vserver2 openais[6643]: [CMAN ] cman killed by node 1
because we rejoined the cluster without a full restart
Feb 11 14:20:49 vserver2 gfs_controld[6679]: cluster is down, exiting
Feb 11 14:20:49 vserver2 dlm_controld[6673]: groupd is down, exiting
Feb 11 14:20:49 vserver2 fenced[6667]: cluster is down, exiting
Feb 11 14:20:49 vserver2 kernel: dlm: closing connection to node 2
Feb 11 14:21:15 vserver2 ccsd[6634]: Unable to connect to cluster
infrastructure after 30 seconds.
Feb 11 14:21:45 vserver2 ccsd[6634]: Unable to connect to cluster
infrastructure after 60 seconds.
Feb 11 14:22:15 vserver2 ccsd[6634]: Unable to connect to cluster
infrastructure after 90 seconds.


-  
_____________________________
Marcos Ferreira da Silva
DiGital Tecnologia
Uberlândia - MG
(34) 9154-0150 / 3226-2534


Em Seg, 2008-02-11 às 09:25 -0500, Lon Hohberger escreveu:
> On Sat, 2008-02-09 at 07:16 -0500, Marcos Ferreira da Silva wrote:
> > I start my cluster but the nodes don't see each other.
> > 
> > [root vserv3 ~]# clustat
> > Member Status: Quorate
> > 
> >   Member Name                        ID   Status
> >   ------ ----                        ---- ------
> >   vserv3.teste.br                      1 Online, Local, rgmanager
> >   vserv4.teste.br                      2 Offline
> > 
> >   Service Name         Owner (Last)                   State
> >   ------- ----         ----- ------                   -----
> >   service:gfsweb       (none)                         stopped
> 
> Fencing configured?
> 
> Any 'totem' messages?
> 
> -- Lon
> 
> 




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]