[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Linux-cluster] no version for "gfs2_unmount_lockproto"



Hi,

I've compiled cluster-2.01.00 against Linux 2.6.23.16.  On modprobe
gfs I got the following two kernel messages:

gfs: no version for "gfs2_unmount_lockproto" found: kernel tainted.
GFS 2.01.00 (built Feb 12 2008 14:42:50) installed

Strange.  I went on, and the mount command froze (Ctrl-C can't kill
it, though it isn't in D state: it's consuming 5% of CPU) with these
messages:

Trying to join cluster "lock_dlm", "pilot:test"
Joined cluster. Now mounting FS...
GFS: fsid=pilot:test.4294967295: can't mount journal #4294967295
GFS: fsid=pilot:test.4294967295: there are only 6 journals (0 - 5)

Right before issuing the mount command, cman_tool services reported:

type             level name     id       state       
fence            0     default  00010001 none        
[1 3]
dlm              1     clvmd    00020001 none        
[1 3]

On node 3, the same command reports:

type             level name     id       state       
fence            0     default  00010001 none        
[1 3]
dlm              1     clvmd    00020001 none        
[1 3]
dlm              1     test     00020002 none        
[1 3]
gfs              2     test     00010003 none        
[3]

This node can indeed use the filesystem.  It's running Linux 2.6.23.8
with the same cluster suite.

Anybody has an idea what can be wrong?
-- 
Thanks,
Feri.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]