[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Linux-cluster] SOLVED Netmask bit set to 32 in service ip



On Fri, 2008-02-15 at 10:13 +0200, Pavlos Parissis wrote:

> It works now and I know why it didn't work before.

Actually, it's luck... see below. ;)

> The last time I saved a copy of the ip.sh under /usr/share/cluster,  
> reading you comment bellow I can guess that the backup file was used  
> and not the patched file, even the backup file had a name ip.sh-bak.

It's because readdir() doesn't necessarily read things in alphabetic
sort order.  So, if the directory entry for 'ip.sh-original' came before
'ip.sh', 'ip.sh-original' would get picked as the provider for the 'ip'
resource.

However, if you remove a file or two and create new ones, there's a
chance that the directory entry might come after 'ip.sh'... making
things work!

The rule to remember is that we won't use anything in /usr/share/cluster
that does not have the execute permissions bit set, so you can create
backups in /usr/share/cluster -- just 'chmod -x' them :)

The theory for this mode of operation is that we don't have to impose
file name extension requirements on users and developers (for example,
SAP* have no extensions - they were developed by the open source
community)...

> I am sorry but I did expect from the cluster to pick up the backup file.

...The downside is that it traps unsuspecting users - such as
yourself. :)

Maybe we should put a 'README' file in /usr/share/cluster?  (Or at least
a FAQ entry on the wiki?)

-- Lon


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]