[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Linux-cluster] RH Cluster issue-Network Failover not happening



On Sun, 2007-12-23 at 08:16 +0400, Harun wrote:
> Issue: When network cable is disconnected from the Primary, primary restart
> unclean and the failover to secondary do not happens. The shared drives
> don't get mounted automatically for secondary neither gets it mounted on
> primary, after the primary restarts. I have to then manually shut down both
> Primary and Secondary, and start primary first and then secondary for the
> setup to work fine again.

> I want to test a live production setup... a Linux Cluster with 2 nodes, in
> Linux Advanced Server (Linux DB-Primary 2.4.21-37.ELsmp #1 SMP Wed Sep 7
> 13:28:55 EDT 2005 i686 i686 i386 GNU/Linux ), Oracle data base is running on
> this setup.
> 
> The clumanager version is 1.2.28 and redhat-config-cluster version is 1.0.8
> on both primary and secondary.I want to resolve the issue with out any
> upgradations. Do you think that updating can resolve the issue? If
> upgradation is required please guide how to go ahead. I am trying to resolve
> this issue with out any patch update.
> Is this a configuration problem or some knows issue with the version used.
> 
> Cluster.xml looks like this.
> 
>   <?xml version="1.0" ?> 
> - <cluconfig version="3.0">
>   <clumembd broadcast="no" interval="1000000" loglevel="5" multicast="yes"
> multicast_ipaddress="225.0.0.11" thread="yes" tko_count="25" /> 
>   <cluquorumd loglevel="5" pinginterval="2" tiebreaker_ip="" /> 

Set a tiebreaker_ip if you don't want it to survive network splits.
This IP needs to be on the same network as the IPs which map to the
hosts "DB-Primary" and "DB-Secondary", but must not reside on the hosts
themselves (use a switch IP, another host, or gateway)

Also, set monitor_link to 1 in the service_ipaddress ...

-- Lon


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]