[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Linux-cluster] CS5 / something weird during tests



On Mon, 2008-01-14 at 09:50 +0100, Alain Moulle wrote:
> On Fri, 2008-01-11 at 15:19 +0100, Alain Moulle wrote:
> 
> >> Hi
> >>
> >> On my two-nodes cluster with qdiskd :
> >> when testing CS5 via a ifdown eth0 on node2(where is the heart-beat)
> >> I have a strange behavior : the node2 is rebooted and service
> >> is failovered by node1, fine. But after the reboot of node2 and
> >> re-launch of CS 4 daemons, I can't see via clustat any information
> 
> 
> >CS5 and CS4 do not work together, and do not happily coexist on the same
> >machine.
> 
> Sorry it was a mistake in my email, I only use CS5 on the two-nodes cluster.
> 
> >from rgmanager, and cant't stop it if I try service rgmanager stop ...
> >> It seems to be stalled in a strange state ...
> 
> >cman_tool services output would be helpful
> >-- Lon
> 
> On node where clustat does not display services information:
> [root xena141 ~]# clustat
> msg_open: No such file or directory
> Member Status: Quorate

Not sure what might cause it.  Assuming you have 5.1[.z] installed:

(a) install matching -debuginfo RPM
(b) killall -USR1 clurgmgrd

Then attach /tmp/rgmanager-dump

Also, note that you can't run 'clustat' as non-root, and there's a
chance SELinux is preventing creation of the rgmanager admin socket.

-- Lon


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]