[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Linux-cluster] Setting Up Two Node Cluster..



Hello Guys,

 

I am totally in clustering field and recently involved in a project related to Setting Up a Red Hat Cluster.

I have two RHEL 4.0 Update 2 Servers which I have installed with the following packages each :

 

ccs-1.0.6-0.x86_64.rpm

cman-1.0.8-0.x86_64.rpm

cman-kernel-smp-2.6.9-39.5.x86_64.rpm

cman-kernel-smp-2.6.9-44.7.x86_64.rpm

device-mapper-1.02.25-1.el4.x86_64.rpm

dlm-1.0.1-1.x86_64.rpm

dlm-kernel-smp-2.6.9-37.7.x86_64.rpm

dlm-kernel-smp-2.6.9-39.1.x86_64.rpm

dlm-kernel-smp-2.6.9-42.7.x86_64.rpm

dlm-kernel-smp-2.6.9-46.16.0.8.x86_64.rpm

lib64cluster1-1.03.00-2mdv2008.0.x86_64.rpm

lvm2-cluster-2.01.09-5.0.RHEL4.x86_64.rpm

lvm2-cluster-2.01.14-1.0.RHEL4.x86_64.rpm

lvm2-cluster-2.02.01-1.2.RHEL4.x86_64.rpm

lvm2-cluster-2.02.06-1.0.RHEL4.x86_64.rpm

lvm2-cluster-2.02.21-7.el4.x86_64.rpm

lvm2-cluster-2.02.27-2.el4_6.2.x86_64.rpm

magma-1.0.5-0.x86_64.rpm

magma-plugins-1.0.8-0.x86_64.rpm

rgmanager-1.9.50-0.x86_64.rpm

system-config-cluster-1.0.27-1.0.noarch.rpm

system-config-cluster-1[1].0.27-1.0.noarch.rpm

perl-Crypt-SSLeay-0.51-5.x86_64.rpm

 

On 10.14.236.106 I ran # system-config-cluster and I added the two Node – One itself(10.14.236.106) and the other(10.14.236.108).

I added The ILO as my Fencing Device providing the right credentials.I dint added any Resource and Service as I just want to test whether the two amchines sees wach other or not.

I saved the file and it gave me cluster.conf.

Next I ran

#service ccsd start

#service cman start

That Brought out Cluster Management Option next to Cluster Configuration label.

I transported the cluster.conf manually through scp to the next machine.

Now I too ran the ccsd and cman on the other machine.

Then I ran

#service fenced start

#service rgmanager start

One by one to the two machine.

 

When I ran the command:

 

Member Status: Quorate

 

  Member Name                              Status

  ------ ----                              ------

  BL02DL385                                Online, rgmanager

  BL01DL385                                Online, Local, rgmanager

 

[root BL01DL385 ~]#

 

So My Nodes are seeing each other.Upto this Its Fine.

Now I have one script called tester.sh placed in 106 machine and All I am adding it to Script Section under Resource giving the full path.

Now Again I am restarting the service in order.

Now The Cluster.conf file is same in both the system

Say,if I reboot the 106 system, Will the next Server show running the script?????

 

Please Advise.


This e-mail and any attachment is for authorised use by the intended recipient(s) only. It may contain proprietary material, confidential information and/or be subject to legal privilege. It should not be copied, disclosed to, retained or used by, any other party. If you are not an intended recipient then please promptly delete this e-mail and any attachment and all copies and inform the sender. Thank you.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]