[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Linux-cluster] Cluster issues



Hi-

Are you able to use the mount command to manually mount your volumes when the cluster services are stopped? If you get errors just doing that, then the cluster has nothing to do with it. Maybe if you had set up multipath before and tried to undo it, you didn't undo it all the way.

-Andrew L

----- Original Message -----
From: "punit_j" <punit_j rediffmail com>
To: "Andrew Lacey" <alacey brynmawr edu>
Cc: "linux clustering" <linux-cluster redhat com>
Sent: Thursday, June 26, 2008 6:05:10 AM GMT -05:00 US/Canada Eastern
Subject: Re: Re: [Linux-cluster] Cluster issues

 
Hi Andrew,

Thanks for the response. I have single path with fibre attached to only one controller. I has issues in multipath so i moved to single path. In this case then it should not be a problem right ? but  still i see these errors while mounting SAN device.I am using e2label to assign names to drive and those names are being used in mounting.


Any clue ? Thanks in advance.
Regards,
- Punit

On Thu, 26 Jun 2008 Andrew Lacey wrote :
>Correction: I meant that your device nodes for the SAN volumes will be in /dev/mapper, not your mountpoints, which are wherever you want them to be :-)
>
>-Andrew L
>
>----- Original Message -----
> From: "punit_j" <punit_j rediffmail com>
>To: linux-cluster redhat com
>Sent: Wednesday, June 25, 2008 2:53:43 PM GMT -05:00 US/Canada Eastern
>Subject: [Linux-cluster] Cluster issues
>
>
>
>
>Hi All,
>
>I have installed zimbra mailbox server in 2+1 cluster. I am facing following issues while configuring Redhat cluster suite: -
>
>2 services -
>mb1-cluster.ku.edu.kw
>mb2-cluster.ku.edu.kw
>
>I have only IP and mount points which are used using LABEL assigned to them. When i reboot all the 3 nodes mount points dont come up and i am getting following errors in log file. Attached is the cluster.conf for reference and also below are logs mentioned : -
>
>These logs are on 1st node : -
>
>Jun 25 11:13:15 mb1 clurgmgrd[14825]: Resource Group Manager Starting
>Jun 25 11:13:15 mb1 clurgmgrd[14825]: Loading Service Data
>Jun 25 11:13:17 mb1 clurgmgrd[14825]: Initializing Services
>Jun 25 11:13:17 mb1 clurgmgrd: [14825]: /dev/sdh1 is not mounted
>Jun 25 11:13:17 mb1 clurgmgrd: [14825]: stop: Could not match LABEL=MB2-BACKUP with a real device
>Jun 25 11:13:17 mb1 clurgmgrd[14825]: stop on fs:MB2-BACKUP returned 2 (invalid argument(s))
>Jun 25 11:13:17 mb1 clurgmgrd: [14825]: stop: Could not match LABEL=MB2-STORE with a real device
>Jun 25 11:13:17 mb1 clurgmgrd[14825]: stop on fs:MB2-STORE returned 2 (invalid argument(s))
>Jun 25 11:13:17 mb1 clurgmgrd: [14825]: stop: Could not match LABEL=MB2-DBDATA with a real device
>Jun 25 11:13:17 mb1 clurgmgrd[14825]: stop on fs:MB2-DBDATA returned 2 (invalid argument(s))
>Jun 25 11:13:17 mb1 clurgmgrd: [14825]: stop: Could not match LABEL=MB2-CONF with a real device
>Jun 25 11:13:17 mb1 clurgmgrd[14825]: stop on fs:MB2-CONF returned 2 (invalid argument(s))
>Jun 25 11:13:17 mb1 clurgmgrd: [14825]: stop: Could not match LABEL=MB2-REDOLOG with a real device
>Jun 25 11:13:17 mb1 clurgmgrd[14825]: stop on fs:MB2-REDOLOG returned 2 (invalid argument(s))
>Jun 25 11:13:17 mb1 clurgmgrd: [14825]: stop: Could not match LABEL=MB2-INDEX with a real device
>Jun 25 11:13:17 mb1 clurgmgrd[14825]: stop on fs:MB2-INDEX returned 2 (invalid argument(s))
>Jun 25 11:13:17 mb1 clurgmgrd: [14825]: stop: Could not match LABEL=MB2-LOG with a real device
>Jun 25 11:13:17 mb1 clurgmgrd[14825]: stop on fs:MB2-LOG returned 2 (invalid argument(s))
>Jun 25 11:13:17 mb1 clurgmgrd: [14825]: stop: Could not match LABEL=MB2-TEST-CLUST with a real device
>Jun 25 11:13:17 mb1 clurgmgrd[14825]: stop on fs:MB2-CLUSTER returned 2 (invalid argument(s))
>Jun 25 11:13:22 mb1 clurgmgrd: [14825]: /dev/sdg1 is not mounted
>Jun 25 11:13:27 mb1 clurgmgrd: [14825]: /dev/sdf1 is not mounted
>Jun 25 11:13:33 mb1 clurgmgrd: [14825]: /dev/sde1 is not mounted
>Jun 25 11:13:38 mb1 clurgmgrd: [14825]: /dev/sdd1 is not mounted
>Jun 25 11:13:43 mb1 clurgmgrd: [14825]: /dev/sdc1 is not mounted
>Jun 25 11:13:45 mb1 rgmanager: clurgmgrd startup failed
>Jun 25 11:13:48 mb1 clurgmgrd: [14825]: /dev/sdb1 is not mounted
>Jun 25 11:13:53 mb1 clurgmgrd: [14825]: /dev/sda1 is not mounted
>Jun 25 11:13:58 mb1 clurgmgrd[14825]: Services Initialized
>Jun 25 11:14:01 mb1 clurgmgrd[14825]: Logged in SG "usrm::manager"
>Jun 25 11:14:01 mb1 clurgmgrd[14825]: Magma Event: Membership Change
>Jun 25 11:14:01 mb1 clurgmgrd[14825]: State change: Local UP
>Jun 25 11:14:01 mb1 clurgmgrd[14825]: State change: mbstandby.ku.edu.kw UP
>Jun 25 11:14:03 mb1 clurgmgrd[14825]: Magma Event: Membership Change
>Jun 25 11:14:03 mb1 clurgmgrd[14825]: State change: mb2.ku.edu.kw UP
>
>On STANDBY NODE
>
>forgot to add standby server logs: -
>
>Jun 25 11:13:26 mbstandby clurgmgrd[15850]: Resource Group Manager Starting
>Jun 25 11:13:26 mbstandby clurgmgrd[15850]: Loading Service Data
>Jun 25 11:13:27 mbstandby clurgmgrd[15850]: Initializing Services
>Jun 25 11:13:27 mbstandby clurgmgrd: [15850]: /dev/sdl1 is not mounted
>Jun 25 11:13:27 mbstandby clurgmgrd: [15850]: /dev/sdp1 is not mounted
>Jun 25 11:13:32 mbstandby clurgmgrd: [15850]: /dev/sdk1 is not mounted
>Jun 25 11:13:32 mbstandby clurgmgrd: [15850]: /dev/sdn1 is not mounted
>Jun 25 11:13:38 mbstandby clurgmgrd: [15850]: /dev/sdj1 is not mounted
>Jun 25 11:13:38 mbstandby clurgmgrd: [15850]: /dev/sdo1 is not mounted
>Jun 25 11:13:43 mbstandby clurgmgrd: [15850]: /dev/sdi1 is not mounted
>Jun 25 11:13:43 mbstandby clurgmgrd: [15850]: /dev/sdm1 is not mounted
>Jun 25 11:13:47 mbstandby sshd(pam_unix)[17583]: session opened for user root by (uid=0)
>Jun 25 11:13:48 mbstandby clurgmgrd: [15850]: /dev/sdd1 is not mounted
>Jun 25 11:13:48 mbstandby clurgmgrd: [15850]: /dev/sdh1 is not mounted
>Jun 25 11:13:53 mbstandby clurgmgrd: [15850]: /dev/sdg1 is not mounted
>Jun 25 11:13:53 mbstandby clurgmgrd: [15850]: /dev/sdc1 is not mounted
>Jun 25 11:13:56 mbstandby rgmanager: clurgmgrd startup failed
>Jun 25 11:13:58 mbstandby clurgmgrd: [15850]: /dev/sdf1 is not mounted
>Jun 25 11:13:58 mbstandby clurgmgrd: [15850]: /dev/sdb1 is not mounted
>Jun 25 11:14:04 mbstandby clurgmgrd: [15850]: /dev/sde1 is not mounted
>Jun 25 11:14:04 mbstandby clurgmgrd: [15850]: /dev/sda1 is not mounted
>Jun 25 11:14:09 mbstandby clurgmgrd[15850]: Services Initialized
>Jun 25 11:14:09 mbstandby clurgmgrd[15850]: Logged in SG "usrm::manager"
>Jun 25 11:14:09 mbstandby clurgmgrd[15850]: Magma Event: Membership Change
>Jun 25 11:14:09 mbstandby clurgmgrd[15850]: State change: Local UP
>Jun 25 11:14:12 mbstandby clurgmgrd[15850]: Magma Event: Membership Change
>Jun 25 11:14:12 mbstandby clurgmgrd[15850]: State change: mb1.ku.edu.kw UP
>Jun 25 11:14:13 mbstandby clurgmgrd[15850]: Resource groups locked; not evaluating
>Jun 25 11:14:14 mbstandby clurgmgrd[15850]: Magma Event: Membership Change
>Jun 25 11:14:14 mbstandby clurgmgrd[15850]: State change: mb2.ku.edu.kw UP
>Jun 25 11:49:22 mbstandby sshd(pam_unix)[9438]: session opened for user root by (uid=0)
>
>Can anyone help me in this issue. Its really urgent. So request you for help.
>
>
>
>
>
>Sig_3million_578x38.gif
>-- Linux-cluster mailing list Linux-cluster redhat com https://www.redhat.com/mailman/listinfo/linux-cluster




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]