[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Linux-cluster] 3 node cluster problems



 

I have NO fencing equipment

 

I have been task to setup a 3 node cluster

 

 

Currently I have having problems getting cman(fence) to start

 

Fence will try to start up during cman start up but will fail

I tried to run /sbin/fenced –D    - I get the following

1206373475 cman_init error 0 111

 

 

Here’s my cluster.conf file

 

<?xml version="1.0"?>

<cluster alias="csarcsys51" config_version="26" name="csarcsys51">

        <fence_daemon clean_start="0" post_fail_delay="0" post_join_delay="3"/>

        <clusternodes>

                <clusternode name="csarcsys1-eth0.xxx.xxxx.nasa.gov" nodeid="1" votes="1">

                        <fence/>

                </clusternode>

                <clusternode name="csarcsys2-eth0.xxx.xxxx.nasa.gov" nodeid="2" votes="1">

                        <fence/>

                </clusternode>

                <clusternode name="csarcsys3-eth0.xxx.xxxxnasa.gov" nodeid="3" votes="1">

                        <fence/>

                </clusternode>

        </clusternodes>

        <cman/>

        <fencedevices/>

        <rm>

                <failoverdomains>

                        <failoverdomain name="csarcsys-fo" ordered="1" restricted="0">

                                <failoverdomainnode name="csarcsys1-eth0.xxx.xxxx.nasa.gov" priority="1"/>

                                <failoverdomainnode name="csarcsys2-eth0.xxx.xxxx.nasa.gov" priority="1"/>

                               <failoverdomainnode name="csarcsys2-eth0.xxx.xxxx.nasa.gov" priority="1"/>

                        </failoverdomain>

                </failoverdomains>

                <resources>

                        <ip address="xxx.xxx.xxx.xxx" monitor_link="1"/>

                        <fs device="/dev/sdc1" force_fsck="0" force_unmount="1" fsid="57739" fstype="ext3" mountpo

int="/csarc-test" name="csarcsys-fs" options="rw" self_fence="0"/>

                        <nfsexport name="csarcsys-export"/>

                        <nfsclient name="csarcsys-nfs-client" options="no_root_squash,rw" path="/csarc-test" targe

t="xxx.xxx.xxx.*"/>

                </resources>

        </rm>

</cluster>

 

 

 

Messages from the logs

ar 24 13:24:19 csarcsys2-eth0 ccsd[24888]: Cluster is not quorate.  Refusing connection.

Mar 24 13:24:19 csarcsys2-eth0 ccsd[24888]: Error while processing connect: Connection refused

Mar 24 13:24:20 csarcsys2-eth0 ccsd[24888]: Cluster is not quorate.  Refusing connection.

Mar 24 13:24:20 csarcsys2-eth0 ccsd[24888]: Error while processing connect: Connection refused

Mar 24 13:24:21 csarcsys2-eth0 ccsd[24888]: Cluster is not quorate.  Refusing connection.

Mar 24 13:24:21 csarcsys2-eth0 ccsd[24888]: Error while processing connect: Connection refused

Mar 24 13:24:22 csarcsys2-eth0 ccsd[24888]: Cluster is not quorate.  Refusing connection.

Mar 24 13:24:22 csarcsys2-eth0 ccsd[24888]: Error while processing connect: Connection refused

Mar 24 13:24:23 csarcsys2-eth0 ccsd[24888]: Cluster is not quorate.  Refusing connection.

Mar 24 13:24:23 csarcsys2-eth0 ccsd[24888]: Error while processing connect: Connection refused

 

 


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]