[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Linux-cluster] RHCS / DRBD / MYSQL



Hiyas,

I'm having some slight issues getting RHCS to work with drbd/asterisk/mysql. Basically I've got a service configured which (as far as I know) should bring up an IP address, set itself to the DRBD primary, mount the MySQL DRBD partition and then proceed to start up mysql/asterisk.

I can see it bringing the IP up, setting itself as the DRBD primary and even mounting the partition, yet it fails to bring up asterisk/mysql. Could anyone take a look at my clusterconf - see below.

<?xml version="1.0"?>
<cluster name="asterisk" config_version="23">
   <fence_daemon clean_start="0" post_fail_delay="0" post_join_delay="5"/>
   <cman two_node="1" expected_votes="1"/>
   <clusternodes>
      <clusternode name="asterisktest01" votes="1" nodeid="1">
         <fence>
            <method name="single">
               <device name="asterisktest01" ipaddr="10.0.0.1"/>
            </method>
         </fence>
      </clusternode>
      <clusternode name="asterisktest02" votes="1" nodeid="2">
         <fence>
            <method name="single">
               <device name="asterisktest02" ipaddr="10.0.0.2"/>
            </method>
         </fence>
      </clusternode>
   </clusternodes>
   <fencedevices>
      <fencedevice agent="fence_vi3" name="asterisktest01" ipaddr="vc01.maxnet.net.nz" login="fence_vmware" passwd="fence123" vmname="asterisktest01"/>
      <fencedevice agent="fence_vi3" name="asterisktest02" ipaddr="vc01.maxnet.net.nz" login="fence_vmware" passwd="fence123" vmname="asterisktest02"/>
   </fencedevices>
   <rm>
      <failoverdomains>
         <failoverdomain name="asterisk" ordered="0" restricted="1">
            <failoverdomainnode name="asterisktest01" priority="1"/>
            <failoverdomainnode name="asterisktest02" priority="1"/>
         </failoverdomain>
      </failoverdomains>
      <service name="asterisk" autostart="1" domain="asterisk">
         <ip address="192.168.111.1" monitor_link="1">
            <script name="drbdcontrol" file="/etc/init.d/drbdcontrol">
               <fs name="mysql_disk" device="/dev/drbd0" mountpoint="/var/lib/mysql">
                  <script name="mysql" file="/etc/init.d/mysql"/>
                  <script name="asterisk" file="/etc/init.d/asterisk"/>
               </fs>
            </script>
         </ip>
      </service>
   </rm>
</cluster>

Any enlightenment would be much appreciated :)

Regards,

Arjuna Christensen | Systems Engineer 
Maximum Internet Ltd
7a Parkhead Pl, Albany, North Shore, 0632 | PO Box 8006, Auckland, 1150, NZ
DDI: + 64 9 913 9683 | Ph: +64 9 915 1825 | Fax:: +64 9 300 7227
arjuna christensen maxnet co nz| www.maxnet.co.nz
________________________________ 
Maxnet | mission critical internet 
________________________________ 
This email (including any attachments) is confidential and intended only for the person to whom it is addressed. 
If you have received this email in error, please notify the sender immediately and erase all copies of this message 
and attachments. The views expressed in this email do not necessarily reflect those held by Maxnet.




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]