[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Linux-cluster] lock issue with gfs and gfs2



On Tue, Oct 14, 2008 at 09:33:19PM -0700, Vipin Sharma wrote:
> Hi,
> 

> Let me try to explain my issue with gfs/gfs2 filesystem. I have two node
> cluster and a shared gfs filesystem which is mounted on both the nodes
> at the same time. I can access the filesystem from both nodes.  1. From
> node A I put a lock on a file called testfile and tried to put the lock
> on testfile from node B. I get message, file is already locked, which is
> good since file is locked from ndoe A.  2. Now unmount the filesystem on
> node B while lock is still there on testfile from node A and mount it
> back. Now try to put lock on the testfile from node B which is locked
> from node A. Expected result would be not to succeed in puting lock from
> node B, but "NO" I am able to put the lock from node B.  3. Node B does
> not know that there is some lock on testfile form node A but now if you
> release the lock from node A and put it again and then try to put lock
> on testfile from node B it works as expected means you will not be able
> to put lock on testfile. It says file is already locked.
> 
> It does not make any difference if I use gfs or gfs2 test works same way
> I tried on Oracle enterprise linux 5.1 and 5.2, which is nothing but
> redhat. Also node A or node B test results are same.

gfs_controld uses checkpoints to sync plock state to new nodes; it appears
that there's something going wrong with that.  After running your simple
test, run 'group_tool dump gfs <name>' from both nodes and include the
output in the bz.

Thanks,
Dave


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]