[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Linux-cluster] rgmanager stop just hangs, clurgmgrd never terminates



Hi Arwin,

I have the same problem on a two-node cluster (two KVM vitual machines)
and on another two-node cluster with real Dell servers. If I flush
iptables rules BEFORE starting cman, everything works fine. But if I
start cman and rgmanager with iptables rules, I see no services and
rgmanager hangs. Flusing iptables rules after starting cman changes
anything. :-(

I have all ports open as stated by RHCS manual, but it wasn't enough. I
still cannot find why rgmanager hangs and which rules my iptables setup
is missing, but I have the same behaviour on another setup with two
VMware virtual machines.

I don't use qdisk, clvmd nor gfs. My clustert setup has clean_start="1"
on fenced. I'm on RHEL5.2, tried both 32 and 64-bits.

Have you tried starting your cluster with no firewall?


[]s, Fernando Lozano

> Hey all,
>
>  
>
> I ran into an issue where my cluster was quorate but none of the
> services were showing up via the clustat command.  When I tried to do
> a /sbin/service rgmanager stop, it hangs indefinitely.  The sigterm is
> sent but the clurgmgrd processes don’t stop.  What I ended up doing
> was manually kill off clurgmgrd, remove the pid file from /var/run/,
> restart cman and ultimately had to restart clvmd.  I’m on RHEL5U3
> (x86_64), 2 node with a qdisk.  I’m also having this same rgmanager
> hang on RHEL5U2 (x86_64) 3 node.  Am I doing something wrong here?
>
>  
>
> Thanks,
>
> Arwin
>
> ------------------------------------------------------------------------
>
> --
> Linux-cluster mailing list
> Linux-cluster redhat com
> https://www.redhat.com/mailman/listinfo/linux-cluster


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]