[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

RE: [Linux-cluster] rgmanager stop just hangs, clurgmgrd never terminates



Yup, matter of fact, I disabled iptables altogether.  The cluster comes up fine and I have services running once again (this is a test setup btw). Just to let you know I managed to get the cluster in this state when I was doing some failover testing.  I'm just wondering why when I do a /sbin/service rgmanager {stop|restart} it hangs indefinitely.

Btw, a question about that clean_start directive.  I'm reading the fenced man page and will the value of "1" prevent a fencing loop at startup.  I've seen it where I bring up 1 node, and then bring up node 2 and node 2 fences node1 and I see this in the log:

Apr  1 22:47:14 oilfish openais[4643]: [CPG  ] got joinlist message from node 1
Apr  1 22:47:14 oilfish openais[4643]: [CPG  ] got joinlist message from node 2
Apr  1 22:47:15 oilfish openais[4643]: [CMAN ] cman killed by node 2 because we rejoined the cluster without a full restart

Arwin

-----Original Message-----
From: linux-cluster-bounces redhat com [mailto:linux-cluster-bounces redhat com] On Behalf Of Fernando Lozano
Sent: Thursday, April 02, 2009 10:38 AM
To: linux clustering
Subject: Re: [Linux-cluster] rgmanager stop just hangs, clurgmgrd never terminates

Hi Arwin,

I have the same problem on a two-node cluster (two KVM vitual machines)
and on another two-node cluster with real Dell servers. If I flush
iptables rules BEFORE starting cman, everything works fine. But if I
start cman and rgmanager with iptables rules, I see no services and
rgmanager hangs. Flusing iptables rules after starting cman changes
anything. :-(

I have all ports open as stated by RHCS manual, but it wasn't enough. I
still cannot find why rgmanager hangs and which rules my iptables setup
is missing, but I have the same behaviour on another setup with two
VMware virtual machines.

I don't use qdisk, clvmd nor gfs. My clustert setup has clean_start="1"
on fenced. I'm on RHEL5.2, tried both 32 and 64-bits.

Have you tried starting your cluster with no firewall?


[]s, Fernando Lozano

> Hey all,
>
>  
>
> I ran into an issue where my cluster was quorate but none of the
> services were showing up via the clustat command.  When I tried to do
> a /sbin/service rgmanager stop, it hangs indefinitely.  The sigterm is
> sent but the clurgmgrd processes don’t stop.  What I ended up doing
> was manually kill off clurgmgrd, remove the pid file from /var/run/,
> restart cman and ultimately had to restart clvmd.  I’m on RHEL5U3
> (x86_64), 2 node with a qdisk.  I’m also having this same rgmanager
> hang on RHEL5U2 (x86_64) 3 node.  Am I doing something wrong here?
>
>  
>
> Thanks,
>
> Arwin
>
> ------------------------------------------------------------------------
>
> --
> Linux-cluster mailing list
> Linux-cluster redhat com
> https://www.redhat.com/mailman/listinfo/linux-cluster

--
Linux-cluster mailing list
Linux-cluster redhat com
https://www.redhat.com/mailman/listinfo/linux-cluster


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]