[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Linux-cluster] really reliable?



Spencer Parker wrote:
My fencing is setup properly as all of my services start and stop correctly. No modifications with scripts and done according to redhat standards. I'm using RHEL. The NFS share gets mounted properly, but when it runs a status on the nfs mount it fails. I have checked to see that it is mounting it as needed(rw access, etc.). This basically causes all of my other services to fail since they rely on this nfs mount to be done first. This is where all of my MySQL data is living at. It also likes to mount the nfs mount multiple times as well. It never actually unmounts the share.


Spencer,

Could you please post your problem in a separate thread ? I think it really confuses when having two different problems in one thread. And more information such as log, if you use NFS over GFS ... will be more helpful in troubleshooting.


Thanks,

Vu


On Tue, Apr 14, 2009 at 10:44 AM, Gordan Bobic <gordan bobich net <mailto:gordan bobich net>> wrote:

    What distro are you using? I've found that:

    1) Distros other than RHEL/CentOS can be quirky when it comes to using
    RHCS. I've even run into problems on Fedora more than once (not to
    mention
    that FC hasn't shipped GFS1 since FC5 and GFS2 hasn't been deemed
    production stable until last month - and we're up to FC10 now).

    2) Starting RHCS components using anything except the intended init
    scripts
    tends to cause problems.

    3) Source of 99% of problems in the rest of the cases (i.e. not
    covered by
    1) and 2) above) is incorrectly configured fencing.

    Does your setup fall under either of the first two categories?
    Have you verified beyond doubt that your fencing is configured correctly
    and that the fencing script gets verification upon success?

    Gordan

    On Tue, 14 Apr 2009 12:17:44 -0400, Ryan Golhar <golharam umdnj edu
    <mailto:golharam umdnj edu>> wrote:
     > Hi all,
     >
     > Is redhat cluster suite really reliable?  I've been having so much
     > trouble getting a cluster up and running, I'm beginning to second
    guess
     > my decision to use this software stack.
     >
     > I have 3 nodes (eventually 10) running and set up.  The fencing
    method
     > is by a brocade fibre switch.  The ultimate goal of this cluster
    is to
     > shared a SAN connected by fibre.
     >
     > I've installed just the bare minimum (before even getting to GFS) to
     > test the cluster software.  Just starting cman cluster services
    fails on
     > two of the nodes.
     >
     > Even when I try to reboot the nodes, I can't because the whole system
     > hangs on various processes that don't ever shut down.  I have to
     > physically reboot these boxes.
     >
     > The logs fill up with errors about not being able to connect to cman,
    etc.
     >
     > I've been at it for awhile now and am not sure this is the best route
     > anymore.
     >
     > Ryan

    --
    Linux-cluster mailing list
    Linux-cluster redhat com <mailto:Linux-cluster redhat com>
    https://www.redhat.com/mailman/listinfo/linux-cluster



------------------------------------------------------------------------

--
Linux-cluster mailing list
Linux-cluster redhat com
https://www.redhat.com/mailman/listinfo/linux-cluster


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]