[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Linux-cluster] sanity check



can someone please look at the attached config and let me know if anything looks 
blatantly wrong.. This cluster config was working earlier for my httpd and postfix 
services , but now the virtual cluster ip address (.7) wont come up any more and the 
httpd and postfix will therefore not start. Im not sure why.

Jason

<?xml version="1.0"?>
<cluster config_version="25" name="mycluster">
	<fence_daemon clean_start="0" post_fail_delay="0" post_join_delay="3"/>
	<clusternodes>
		<clusternode name="server1" votes="1">
			<fence>
				<method name="1">
					<device name="apc_power_switch" option="off" port="1" switch="1"/>
					<device name="apc_power_switch" option="off" port="2" switch="1"/>
					<device name="apc_power_switch" option="on" port="1" switch="1"/>
					<device name="apc_power_switch" option="on" port="2" switch="1"/>
				</method>
			</fence>
		</clusternode>
		<clusternode name="server2" votes="1">
			<fence>
				<method name="1">
					<device name="apc_power_switch" option="off" port="3" switch="1"/>
					<device name="apc_power_switch" option="off" port="4" switch="1"/>
					<device name="apc_power_switch" option="on" port="3" switch="1"/>
					<device name="apc_power_switch" option="on" port="4" switch="1"/>
				</method>
			</fence>
		</clusternode>
	</clusternodes>
	<cman expected_votes="1" two_node="1"/>
	<fencedevices>
		<fencedevice agent="fence_apc" ipaddr="192.168.1.8" login="xxxxxxx" name="apc_power_switch" passwd="xxxxxxxxxxxxx"/>
	</fencedevices>
	<rm>
		<failoverdomains>
			<failoverdomain name="httpd" ordered="1" restricted="1">
				<failoverdomainnode name="server1" priority="1"/>
				<failoverdomainnode name="server2" priority="2"/>
			</failoverdomain>
		</failoverdomains>
		<resources>
			<script file="/etc/init.d/httpd" name="cluster_apache"/>
			<ip address="192.168.1.7" monitor_link="1"/>
			<script file="/etc/init.d/postfix" name="cluster_posstfix"/>
		</resources>
		<service autostart="1" domain="httpd" name="Apache Service">
			<ip ref="192.168.1.7"/>
			<script ref="cluster_apache"/>
		</service>
		<service autostart="1" domain="httpd" name="postfix service">
			<ip ref="192.168.1.7"/>
			<script ref="cluster_posstfix"/>
		</service>
	</rm>
</cluster>

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]