[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Linux-cluster] cluster-3.0.0 problems starting up



On Tue, 2009-08-18 at 16:28 -0700, Steven Dake wrote:
> On Tue, 2009-08-18 at 13:44 -0700, Trevor Peirce wrote:
> > Trevor Peirce wrote:
> > > Aug 14 15:24:58 localhost corosync[28324]:   [MAIN  ] parse error in 
> > > config: parse error in config: .
> > > Aug 14 15:24:58 localhost corosync[28324]:   [MAIN  ] Corosync Cluster 
> > > Engine exiting with status -9 at main.c:879.
> > 
> > Have I found a dead end?
> > 
> > Perhaps someone would be so kind as to send the most simple cluster.conf
> > file that is known to work so I can try it out?
> > 
> > Or any ideas what this error means?
> > 
> > Thanks,
> > 
> 
> Trevor,
> 
> This means your XML format is invalid.  We are working on better error
> reporting when the XML format is invalid rather then this cryptic error.
> In the meantime, you can run strace -f cman, and libxml will print the
> errors in write system calls.  If you need help analyzing this output,
> send a link to the output from strace.

That's odd; I ran it through xmllint with no errors - that's why I'm
confused.

There is probably a bug in the schema (i.e. something should be
"required" that isn't) if the config is invalid:

[lhh localhost xml]$ git status | grep branch
# On branch stable3
[lhh localhost xml]$ xmllint --relaxng ./cluster.rng /tmp/trevor.xml 
<?xml version="1.0"?>
<cluster name="TestCluster" config_version="3">
  <clusternodes><clusternode name="guinneapig" votes="1"
nodeid="1"/></clusternodes>
  <rm>
    <failoverdomains/>
    <resources/>
  </rm>
</cluster>
/tmp/trevor.xml validates

-- Lon


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]