[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Linux-cluster] fence_node fails for fence_wti agent - cluster 3.0



Marek any idea on this problem?

Fabio

On Fri, 2009-08-14 at 22:13 -0400, Thomas Sjolshagen wrote:
> Hi,
> 
> I've got a WTI NPS power switch that I've configured as a fence device  
> for my 2-node cluster. If I call 'fence_wti' directly with  
> action=status or action=reboot, it does what I expect it to do; fence  
> the node I'm telling it to fence.
> 
> However, if I issue "fence_node -vv <node>", the command fails with  
> the following error:
> 
> # fence_node -vv node1
> fence node1 dev 0.0 agent fence_wti result: error from agent
> agent args: plug=1 agent=fence_wti ipaddr=1.1.1.1  
> debug-file=/tmp/wti-fence.debug inet4-only=1 verbose=1 ipport=23  
> action=reboot
> fence node1 failed
> 
> Also, there is no /tmp/wti-fence* file and the only entry in the error  
> logs is in /var/log/messages:
> 
> fence_node[19172]: fence virt1-backup.sjolshagen.net failed
> 
> Suggestions on how I can further troubleshoot this or fix the problem?
> 
> Thanks in advance,
> 
> // Thomas
> 
> My cluster.conf file contains the following fencedevice entry:
> 
> <fencedevices>
>     <!-- Definition of fence device named "power", referenced previously -->
>     <fencedevice agent="fence_wti" name="power" ipaddr="1.1.1.1"  
> debug-file="/tmp/wti-fence.debug" inet4-only="1" verbose="1"  
> ipport="23" action="reboot"/>
> </fencedevices>
> `
> And for the clusternodes definitions:
> 
> <clusternodes>
>          <clusternode name="node2" nodeid="1" votes="1">
>                  <fence>
>                          <method name="1">
>                                  <device name="power" plug="1"/>
>                          </method>
>                  </fence>
>          </clusternode>
>          <clusternode name="node2" nodeid="3" votes="1">
>                  <fence>
>                          <method name="1">
>                                  <device name="power" plug="8"/>
>                          </method>
>                  </fence>
>          </clusternode>
> </clusternodes>
> 
> 
> 
> ----------------------------------------------------------------
> This message was sent using IMP, the Internet Messaging Program.
> 
> 
> --
> Linux-cluster mailing list
> Linux-cluster redhat com
> https://www.redhat.com/mailman/listinfo/linux-cluster


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]