[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Linux-cluster] Can not establish new cluster 5.3 with luci - quorum error



I have tried almost everything at this point to try and troubleshoot this further. I can't create new cluster with luci.

I broke and tried to reconfigure 3 node cluster at least 6 times.

I have noticed nodes taking expectational long on initializing fencing upon cman start. I tried with defined and undefined fencing, the amount of time needed is still the same. Even after the fencing is overcome in /var/log/messages nodes refuse to join cluster due to the state of 'not in quorum' during joining process. I uped the post_join_delay as much as 150 but the result is the same.

Fencing - I use APC PW Switches - I can login into apc PWS from the node, I can even fence the other node, but when cman is started it looks like it is almost timign out on staring fencing.

If I issue cman_tool nodes it gives me the local node name as the member of the cluster and the other two with state 'X'. If I try cman_tool join clustername - it tells me the nodes are already in that cluster but cluster as the whole does not register. Each node thinks it's the only working member of the cluster.


Any pointers?



--
Alan A.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]