[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Linux-cluster] how to start/stop a service



Hi

I have the following configuration: 2 nodes with the same
application "fun".
This is the /etc/cluster/cluster.conf

<?xml version="1.0"?>
<cluster alias="FunCluster" config_version="33" name="FunCluster">

  <cman expected_votes="1" two_node="1"/>

    <clusternodes>
        <clusternode name="redhat02.fun.uk" nodeid="1" votes="1">
          <fence/>
        </clusternode>
        <clusternode name="redhat03.fun.uk" nodeid="2" votes="1">
          <fence/>
        </clusternode>
    </clusternodes>

    <fencedevices/>

    <rm>

      <failoverdomains>
<failoverdomain name="red2" nofailback="1" ordered="1" restricted="1">
               <failoverdomainnode name="redhat02.fun.uk" priority="1"/>
          </failoverdomain>
<failoverdomain name="red3" nofailback="1" ordered="1" restricted="1">
               <failoverdomainnode name="redhat03.fun.uk" priority="1"/>
          </failoverdomain>
      </failoverdomains>

      <service autostart="0" domain="red2" name="fun11" recovery="restart">
        <fun name="res11" fun_home="/opt/fun1_1"/>
      </service>

      <service autostart="0" domain="red3" name="fun22" recovery="restart">
        <fun name="res22" fun_home="/opt/fun2_2/"/>
      </service>

    </rm>

    <fence_daemon clean_start="0" post_fail_delay="0" post_join_delay="3"/>

</cluster>



Now I'd like to manage (start/stop) manually both instances
from the node redhat02.fun.uk;

I'm using the command line tool but when I run

clusvcadm -e fun11 -m redhat02.fun.uk

the application starts correctly

when I run

clusvcadm -e fun22 -m redhat03.fun.uk

the output says:

Member redhat03.fun.uk trying to enable service:fun22...Success
service:fun22 is now running on redhat03.fun.uk

but the service is not up and running on the redhat03.fun.uk


can anybody  help me with this issue?

thanks in advance

gilberto


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]